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Preface: Toolbar Overview

Introduction

WebShop comes with a variety of toolbars designed to make it easier to use the various program
features.  You will want to review these before reading the rest of this Quick Start Guide.

Accessing Toolbars Though Different Modules
You access the program toolbars using the View  menu.  Some toolbars are not available with
some screens.  All toolbar buttons have quick tips.  These very short button descriptions display
when you place your cursor over the toolbar button.  There is also Help, which displays at the
bottom of the screen in your Windows Status bar.  The program uses three major modules to
assist you in creating your Web pages.  These are Site Manager, Page Editor, and Frame
Manager.

Site Manager .  This is the entry point into your Web site.  The Site Manager window features
five tabs for accessing the five main areas of Web site design and management.  Site Manager is
covered in more detail in the WebShop User Guide (see the WebShop User Guide “Table of
Contents”).

Page Editor .  This is where you will do most of your page design work.  When you open a page
from Site Manager, you are launching Page Editor.

Frame Manager .  Frame Manager is available when you are in Page Editor.  The Frame
Manager display area is visible only when you use the Frame Manger toggle button.  Use Frame
Manager to organize the display of a Web page when that uses the Frame feature.

Depending upon which module you currently are using only certain toolbars are available.

Toolbar Locations and Docking
The default location for most of the toolbars upon installation is vertically down the right side of
the WebShop window.  This, however, is not necessary true for all toolbars.  Most toolbars can
be undocked and placed elsewhere.  To undock a toolbar, you will want to click and drag the
toolbar header line—the vertical line that demarcates the beginning and end of a toolbar.  If you
undock a toolbar and then re-dock it at a new location, the buttons are arranged in a vertical or
horizontal direction depending upon the new location.
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Main Toolbar

The Main toolbar appears at the top of the WebShop window just below the Main menu.  This
toolbar is standard and does not change when the active window changes.  It also cannot be
moved.

Physical Layout Toolbar

The Physical Layout toolbar displays when the Site Manager–Physical Layout  window is
active.  Use this to manipulate the physical resources for your site.

Logical Layout Toolbar

The Logical Layout toolbar displays when the Site Manager–Logical Layout  window is active.
The Logical Layout window enables you to add, move, and delete individual pages in your Web
site.  It displays an organization-type chart showing the relationship of the pages to one another.
Use the toolbar to manipulate the window display and the arrangement of logical resources
associated with your site.

Navigate Layout Toolbar

The Navigate Layout toolbar displays when the Site Manager–Navigate Layout  window is

active.  The Navigate Layout window displays all of the pages and resources¶ of a Web site.
This view is useful for viewing the relationship of each page to other pages as well as to
external Web sites.  You can open any Web element or image for editing by double-clicking on
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it.  This layout features two views: Spiral and Centered.  In the Centered view, the selected
resource highlighted in the Spiral view is placed in the center, and all the resources that contain
links to it are displayed.  In the Spiral view, all of the selected resources are displayed in a spiral
fashion.  You can selectively choose to include those resources that you want to see.  This view
is designed to give you either a global view of all your Web site resources, or a selective view.
When in Horizontal view, linked items linked items are displayed from top to bottom.  When in
Vertical view, linked items linked items are displayed left and right.  Use this toolbar to
manipulate the Navigate Layout window display or the various links between resources.

Common Objects Toolbar

The Common Objects toolbar displays when the Site Manager–Common Objects  window is
active.  This window enables you to enter any number of headers and footers that you want.
Once they are created, you may then assign any one of them to a page.  This saves you the
tedium of having to complete repetitive tasks for inserting standard information or graphics on
pages.  Use this toolbar to manipulate the window display and to insert, delete, or rename your
common objects.

Styles Toolbar

The Styles toolbar displays when the Site Manager–Styles  window is active.  Use this toolbar
to manipulate the window display and to insert Site Styles from a Style Library.

Frames and Page Editor Toolbar

The Frames and Page Editor toolbar displays when you open a page resource in Page Editor
mode.  This toolbar appears at the top of the Page Editor window and is a fixed part of the
window design.  It also cannot be moved.

To activate Frame Manager, click on the Frame Manger toggle button.  Use this toolbar to
manipulate the window display and to assign Frame-Content Overlays to your Web pages (see
the User Guide for more information about Frame-Content Overlays).
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New Object Toolbar

The New Object toolbar displays when you open a Free Page in Page Editor mode or when
working with Free-Form objects.  Use a Free Page when you want to place graphic or text
objects anywhere on the page.  The Free Page style is the more versatile—you are not limited
by the text line limitations of the simple plain Web page.  If you want to be artistic—that is, if
you want place objects on the page, drag them to a specific location, use the snap to grid option
or even create graphic images with transparent overlaps—then use the Free Page style.  Use the
New Object toolbar to insert a variety of graphic objects.  These include patterns, frames,
artistic and special effects text, drawing tools, calendars.  You can even launch another applica-
tion using the OLE button.

Standard Toolbar

The Standard toolbar displays when you open a page resource that manipulates text.  This
toolbar is automatically displayed and cannot be accessed through the View menu.  Use this
toolbar to change your visual settings, spell check your document, or assign paragraph styles.

Formatting Toolbar

The Formatting toolbar only displays when opened from the View  menu and is only available

when you open a page resource that manipulates text.  The Formatting toolbar includes tools for
implementing format commands.  Use this toolbar when you want to assign display attributes
such as bold, italics, or underscore.
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Insert Object Toolbar

 

The Insert Object toolbar displays on a Free Page only when you are manipulating an object.
With other pages, this toolbar displays when you are in Page Editor and becomes active only
when you are manipulating an object.  The Insert Object toolbar provides quick access to tools
that place various objects on a Web page.

Form Fields Toolbar

The Form Fields toolbar displays when you are inserting a form into a Web page in Page Editor.
Use this toolbar when inserting a form into a Web page.  The toolbar is only active (that is,
visible) when the Form button on the Insert Object toolbar is selected.

Dynamic Page Toolbar

The Dynamic Page toolbar displays only when you are in Page Editor for a Dynamic Page.  It
becomes active only when you click on a tree element in the Dynamic Page Manager.  A
Dynamic Page has three elements.  1.  A Dynamic Page Manager—this is the left frame on the
Dynamic Page window, 2.  A Dynamic Page “editor” display—this is the right frame on the
Dynamic Page window and is same as other Page Editor displays—and 3.  A Frame Manager
window—which you access by using the Frame Manager toggle button, just as you would with
any other page in Page Editor.  The Dynamic Page toolbar allows you to insert or delete
dynamic page elements.  It also allows you to attach a Dynamic Page to your database.  Use this
toolbar only when working with Dynamic Pages.
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Working with WebShop

Introduction

This Quick Start Guide summarizes the primary features of WebShop and employs a step-by-
step approach to showing you how to use them.  The WebShop User Guide covers all of the
program’s features in much greater detail.  This portion of the Quick Start Guide is dedicated to
the construction of a small demonstration Web site.  The demonstration Web site has just a few
pages; however many of WebShop’s most powerful features will be introduced.  Specific
tutorials are used to teach you how to take advantage of the most important features, including a
detailed section on using WebShop’s new Active Server Page (ASP) capability.

After you have created the demonstration Web site, you are encouraged to take the next step—
to set up a powerful E-commerce presence on the Internet by customizing one of the E-Com-
merce templates included with your program CD.  After you have personalized the template to
suit your business, the same step-by-step method will help you upload your new E-commerce
Web site to a Web-server.  If you are upgrading from Internet/Intranet Design Shop GOLD
version 4.x and you want to launch an E-commerce project right away, you can proceed directly
to the chapter titled “Customizing a WebShop Template” in the E-Commerce User Guide.

WebShop features quick button access to the most common development features, so we will
include the button images in the left margin as each feature is described so that you can start to
learn the icons and their operation.

Since menu bar commands are easier to find when you are just starting with a new program, we
will include the sequential menu commands for all operations described.

System Requirements

The minimum installation for WebShop requires approximately 51 Mb. of hard disk space.  The
full installation, including the accompanying libraries and applications, require approximately
278 Mb.  The minimum amount of RAM is 16 Mb., but you will quickly discover that multime-
dia applications like WebShop are RAM-intensive.  Even a beginner will soon require 32 Mb.
to efficiently manage a Web site created from one of the E-commerce templates.  64 Mb.  is the
minimum recommended RAM for advanced users.

It is recommended that you install all of the WebShop software library components.  Through-
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out this Quick Start Guide, we will assume that you installed the all WebShop components and
libraries.  See Installing WebShop in the User Guide for a more complete description of system
requirements.

User Guide Conventions
There are several conventions that you should be familiar with when working with this manual.

1. Commands you are instructed to type and specific content you are instructed to enter are
indicated in a sans-serif font, such as: CD\TEMP with quotation marks.  Ignore any
punctuation included, unless specified within the quotation marks.

2. Keystrokes, or individual keys that you are asked to press or type are indicated with bold,
all capital text, such as: ALT , F1, TAB , ENTER.  Ignore any punctuation included unless
specified otherwise.

3. When you are instructed to select more than one menu option in sequence, the options are
separated by a greater-than sign (>).  The instruction “Select Frames > Advanced >
Rename” asks you to complete these steps in sequence: 1.  Select the Frames  menu; 2.
Select the Advanced  option in the Frames menu; and 3.  Select the Rename  option in the
Advanced menu.

4. When you are instructed to “select,” “click,” or “double-click” with the mouse, use the left
mouse button.  In some cases, you will be instructed to “right-click.” If you have reversed
the configuration of the mouse buttons in Windows, you should reverse the button instruc-
tions in this Quick Start Guide.

5. When you are instructed to “select” or “highlight” an file, icon, or window, click once on it.
In some cases, it will be surrounded by blue or the prevailing “active” Windows system
color.

Note: Program operations in WebShop can be launched by using any one of the following
methods: 1. A sequential menu option selection, as described in 3 above; 2. Clicking on a
program button; 3. Selecting an item or object, right-clicking and then selecting a program
option from the pop-up menu; and 4. Pressing a single or combination shortcut key.

Installing WebShop

WebShop features an Autostart Installation process that starts the installation program when you
place your WebShop CD in the CD drive and close the door.  If the WebShop Welcome  screen
does not appear within a few moments after you close the CD door, follow these steps for
manual installation.

To manually open the installation program

1. Click Start  in the lower left corner of the Program Manager  window.

2. Select the Run  option from the Start menu.
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3. In the Run command box, type “<CD drive>:\setup.exe” where <CD drive> is the letter
that identifies your system’s CD drive.  For example, “D:\setup.exe”

4. Press ENTER to open the installation application.

WebShop’s Installation Program
WebShop comes with an installation program that loads the program into you hard drive.

1. When the WebShop  screen appears, click the Install WebShop  menu option to begin the
installation process.  The Welcome  dialog box appears.

2. Click Next .  The License Agreement  dialog box appears.

Note: The License Agreement dialog box displays the License Agreement for the applica-
tion.

3. When you have read the license agreement and agreed to the terms, click Yes.  The
Choose Destination Location  dialog box appears.

Note: The Choose Destination Location dialog box allows you to change the installation
location on your hard disk.

4. To change the install location, click Browse  and select the new location.

5. When done, click Next .  The Select Component  dialog box appears.

Note:  The Select Component dialog box allows you to customize your installation of
WebShop.  To change the Library and Templates that will be installed, click Change.

6. Select the components that you want to install and click Next .  The Select Program Folder
dialog box appears.

Note:  The Select Program Folder dialog box allows you to customize the Program Group
folder for WebShop.  The default program group is Boomerang Software.

7. Specify a new program group or select one from the list of existing groups.

8. Click Next .  When the installation program finishes, you are prompted to install Internet
Explorer.

Note: If you already have installed Internet Explorer (version 3 or 4), you can ignore this
step.  If you do not have Internet Explorer (version 3 or 4) installed, install it at this time.

9. To install Internet Explorer (version 4), click Yes.  The installation program for Internet
Explorer is launched.

For more information about WebShop installation, see the chapter titled “Installing WebShop”
in the WebShop User Guide.

If you have installed Internet Design Shop Gold, then install WebShop to the Boomerang
Software program folder that currently exists.  After installation, if you cannot see the WebShop
icon in your Boomerang Software program folder, restart your computer.  To restart your
computer, select the Start > Shut Down  from the taskbar Start menu.  The Shut Down Win-
dows dialog box appears.  Select Restart  and press OK.
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Creating Your First WebShop Web Site

To make a quick start, begin by building a simple demonstration Web site promoting a small
business called Tim’s Trains , which deals in electric model train sets and accessories.  For now,
no “shopping cart” functionality will be included.

1. Select the File > New  menu options from the Menu bar.  The New dialog box appears with
a preview box displaying thumbnail pictures of all available template selections.

2. Select the template with an X in the preview box, which does not open an E-commerce
template.  Click OK.

3. WebShop launches the Site Manager feature.  Two default windows appear.  On the left,
there is the Site Manager  window; on the right, the Home Page  window.  By default your
cursor is placed the Page Editor window for the Home Page.

Note:  It is recommended that you do not use an E-commerce template when completing the
tutorials associated with this E-Commerce Guide.  However, if you want to open an E-
Commerce template and modify the Style Sheet associated with the template, see the topic
“Changing the ECStyle for an E-Commerce Template” later in this manual.

Site Manager

Site Manager is module that helps you organize your Web site.  The Home Page window on the
right displays a blank header and a blank footer.  This window is also called a Page Editor
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window.  From here you can edit the Home Page.  WebShop has automatically inserted these
header and footer defaults into your Web site project.  On the left is the Site Manager window.

Site Manager is perhaps the most important element of the WebShop system, providing access
to the main program features using five distinct layout windows:

• Physical Layout .  The Physical Layout window displays the structure of the Web site in a
style similar to Exploring Windows.  All Web site elements are displayed for easy access.

• Logical Layout .  The Logical Layout window uses a hierarchical layout like an organiza-
tion chart, showing the Web site pages and their relationship to one another.  From the
Logical Layout window, you will add, open, and edit your pages.

• Navigate Layout .  The Navigate Layout window displays the pages, links, and resources of
the Web site.  If you import an image, an icon representing that item appears in the Navi-
gate Layout window as a resource.  Single Web pages are represented by Logical Page
icons.  A page divided into two or more frames is also considered a Logical Page.  Re-
source icons represent the individual frames of the page.

• Common Objects .  The Common Object window enables you to create headers and
footers for use on any page.  “Boiler-plate” headers or footers easily handle site contents
that repeat on every page—these can include logos and navigation bars.  If you set up a
default header or footer, you may also want to create unique headers or footers for use
when and where as you please.  WebShop lets you do this.

• Styles .  The Style window enables you to select one of many predefined style sets from a
Styles Library.  These styles control the “look” of your Web pages.  You may select a new
style set for your Web site at any time during development.
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Changing WebShop Preferences

In Site Manager, select the File > Preferences  menu options.  The Preferences dialog box
appears.  This dialog box has four tabs that control different preference selections.  Each tab has
one or more sections:

••••• General  tab .   Undo/Redo section: The default setting is 10.   Startup section: From the
pop-up menu, you may select one of four startup display options you prefer to see when
WebShop is launched.  The Autosave and Files sections are self-explanatory.

••••• Graphic Editor  tab .   Ruler units section: The default setting is inches.  For now, retain
inches as the active setting.   Workspace
section: Retain the default settings for
background colors of new Free pages.
Objects section: Retain the default
object placement setting, center of
visible area.  Grid section: The default
setting is 1 grid-line per inch.  Set
Frequency to 4 gridlines per inch for a
more exact level of control over object
placement

••••• WebSite  tab .   Headers/Footers section:
The default setting compels WebShop to
automatically insert a blank header and
footer in each new page.  Retain the
default setting.   Physical Layout
section: Retain the default setting, which
is a full “tree” display of Web site
elements.

••••• Browsers  tab .   Browsers section:
WebShop uses an internal browser to preview your Web pages.  An external browser may
also be used for this purpose.  At any given time, one browser serves as the “current”
internal browser.  To test with a different browser, it must already be installed on your PC.
To add the new browser to the Browsers  list box, click the Add button and browse for the
program file you want.   Web Promote section: WebShop helps you promote your Web site
to the Internet community by automating part of the registration process with Internet
search engines.  You may choose to add more Internet search engines to the list of search
engines already configured by the WebShop developers.

Changing Style Sets

The test Web site we are creating will have a consistent graphical style.  You control the style of
your site in the Site Manager–Styles  window.  Later, if you create a style set of your own, you
can return to the Styles window and add it to the Styles Library.  Using style sets will save you
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time because with a few mouse clicks you can change the graphical theme of your entire Web
site.  Even if you apply a style set to an entire Web site, you can customize a specific page or
even a specific object on a page.

Note:  It is recommended that you do not use an E-commerce template when completing the
tutorials associated with this E-Commerce Guide.  However, if you want to open an E-
Commerce template and modify the Style Sheet associated with the template, see the topic
“Changing the ECStyle for an E-Commerce Template” later in this manual.

To change a style set

1. From Site Manager, click on the Styles tab.  The Site Manager–Styles window appears.

2. Click Style_A01  from the Library  list box.  A preview of this style is displayed in the
preview area.

3. Highlight Style_A01 , right-click, and select Insert Style  from the pop-up menu.
Style_A01  appears in the Site Styles  list box.  Now you can use this style in the current
project.

4. Select Style_A01  in the Site Styles  list box and right-click.  From the pop-up menu, select
Rename Style .  For this demonstration Web site, type “BlueJeans” and press ENTER.

5. With the style “BlueJeans ” selected, right-click, and select Set as Site Default Style from
the pop-up menu.  You have now set the “BlueJeans” style set as the default site style.

Note: The “BlueJeans” style is now in use. If the Home Page window is open, you will see
the “BlueJeans” style background color displayed.
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Creating a Default Header

Headers and footers are completely optional.  For Tim’s Trains, we will employ a default
header to display a simple banner in the “BlueJeans” style on the Home Page.  Later, you can
create custom headers for use on specific pages.  We recommend that you close all other Web
site pages when you create or edit a header.  If you do not want to use a header or footer, skip
ahead to the procedure “Saving Your Work” (see the Table of Contents).

To create a default header

1. From Site Manager, select the Common Objects tab.  The Site Manager–Common
Objects window appears.  Double-click on the Header1  icon.  The Header1 window opens
with the cursor at the far left.

2. Click on the Center  button on the Formatting toolbar.  The cursor is now centered in the
Header1 workspace.

3. Click the Insert Banner  button on the Insert Objects toolbar.  A banner in the “BlueJeans”
style appears in the Header1  window.  The display text reads “Banner.”

Note:  The display text “Banner” only appears when you insert the banner object.

4. Close the Header1 window.  If the Home Page  window is still open, the banner text
automatically changes to “Index.”

The default text “Index” is not very useful.  Customize the banner text using the Alias feature.

To customize a default header using the Alias feature

1. With the Home Page  window still open, select the banner object.  An object outline
appears.

2. Click the Properties  button on the Standard toolbar.  The Properties  dialog box appears.

3. Click on Alias  check box and press TAB .  The contents of text field box is highlighted.
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4. Type “Tim’s Trains” to overwrite “Index” and click OK.  The banner text now reads
“Tim’s Trains” and uses the “BlueJeans” style.

Entering and Formatting Text

To enter text or other content in a header, footer or the regular work space of a Web page, you
must be in Page Edit mode.  You may enter text in a Web page in a header, footer or normal
work space simply by typing the text.  We will begin entering content into the pages with the
Home Page.

To enter and format text on the Home Page

1. With the Home Page  window still open, click the maximize button to enlarge your display,

2. Click the work space just below the Header and select the Center button on the Formatting
toolbar.  The flashing cursor is now centered below the Header.

3. Tim’s store address should appear beneath the banner.  Type “9899 Round House Road”
and press ENTER.

4. Repeat Step 3 until the following upper and lower case text has been entered:

Topeka, KS 55555
9899 Round House Road
(555) 555-5555
www.timstrains.com
Established in 1970 by hobbyists for hobbyists
Announcing: CUSTOMER APPRECIATION DAYS !
Click here to go to the customer satisfaction survey!

Formatting Text
When text is entered, it automatically takes on the style, height and weight dictated by the Style
setting in the Style menu on the Formatting toolbar.  To achieve an even more elaborate effect,
you may customize text even further.
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To format the text entered on the Home Page

1. With the Home Page  window still open, highlight the postal address, phone number, and
URL address for Tim’s Trains.

2. Select the Format > Font  menu options or select the Font Properties  button in the Stan-
dard toolbar.  The Choose Web Font  dialog box appears.

Note:  This dialog box has four main sections: Font, Font Style, Size, and Color.  The Color
section has two tabs, one to specify font color another to specify a text background color.
You may choose any font available and supported by your PC.

3. Click the Font drop-down box, type “V” and press the DOWN ARROW to select Verdana .

4. Click the Font Style drop-down box and press the DOWN ARROW to select Bold .

5. Click the Font Size  drop-down box and press the DOWN ARROW to select 10.

6. In the Color section, select the Text  tab, click the drop-down box and press the DOWN
ARROW to Custom Colors  from the list box.  The Choose Color  dialog box appears.

Note:  This dialog box enables you to specify a predefined color palette.  It has two main
sections: A drop-down list box and a preview area.

7. Click the drop-down arrow to display a list of available color palettes.  Select the
Browser_Safe_216_Color_Palette .  The palette appears immediately.

8. Select a royal blue shade and select OK.  The Choose Web Font  dialog box reappears.
The Text Color  tab reflects the new color setting.

9. Click OK.  The specified text formatting appears on the Home Page.

Repeat this procedure for the other text phrases, giving each phrase a unique font style.  As you
can see WebShop gives you great flexibility.

Creating a Default Footer

You will create a simple default footer for the Tim’s Trains  Web site.  It is recommended that
you close all other Web page windows before creating this footer.  This footer will include a
horizontal rule, a copyright notice, and a mail to link that says “Send Tim Email.”
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To create a default footer

1. Select the Site Manager–Common Objects tab and double-click on the Footer1  icon to
open the Footer1  window.

2. Click the Center button on the Formatting toolbar.  The cursor is now centered in the
Footer1 workspace.

3. Select the Insert > Horizontal Rule menu option or click the Horizontal Rule  button on the
Insert Objects toolbar.  A horizontal line appears.

Note:  The “BlueJeans” style is applied.  The cursor is positioned at the right edge of the
horizontal line.

4. Press ENTER to position the cursor beneath the horizontal rule and select the Insert >
Copyright  menu option.  The Special Text  dialog box appears.

Note:  This dialog box has three tabs: Date, Mail to, and Copyright.  When first opened, the
Copyright tab is active and the default text is highlighted.  The default text should read
“Copyright © 199X  My Company.  All Rights Reserved.”

5. Select the text “My Company” and  type “Tim’s Trains”

6. Select the text “9X” and type “99”

7. Click OK.  The Footer1  window reappears with the text “Copyright © 1999 Tim's Train.
All Rights Reserved.” displayed.

8. Press ENTER to position the cursor beneath the this text and select the Insert > Mail to
menu option.  The Special Text  dialog box appears.

9. In the top input line, type “tim@timstrains.com” This is Tim’s email address.

10. In the bottom input line, type “Send Tim Email.” This is the hypertext that will launch the
mail to email.

11. Click OK.  The Footer1  window reappears with the text Send Tim Email  displayed in blue.

To format the default footer text

1. With the Footer1  window still open, select the text “Copyright ©  1999 Tim’s Trains .  All
Rights Reserved .”

2. Select Heading6 , H6 from the drop-down Style  menu on the Formatting toolbar.  The text
display is changed.

3. Close the Footer1  window.  The Site Manager–Common Objects window reappears.

This completes our work on the Home page and the default footer.  To display Home Page
Header, Footer and display text, go to Site Manager–Logical Layout and double-click the Home
Page icon.  Then click the Preview icon on the Main toolbar to view this partially constructed
Web site.



WebShop 17

Quick Start Guide

 Saving Your Work

To protect against a loss of power, you should routinely save your WebShop project file as you
work.  It is a good habit to save your work every 15 to 30 minutes.

To save your project file

1. Select the File > Save menu option or click the Save button on the Main toolbar.  The
Save As  dialog box appears.

Note:  This dialog box enables you to specify where on your hard disk you want to save your
project file.  It has three main input lines: Save in, File name and Save as type.

2. In the Save in  input line, select the drive and folder where you want to save your project
file.

3. In the File name  input line, type “TTrains” WebShop automatically adds a *.CNQ file
extension.

Note: Do not attempt to save as an *.HTM or *.HTML file.  The WebShop CNQ file automati-
cally contains all of the HTML files and other Web site resource files, using a convenient
Unified File Structure.  To edit your *.HTML files directly, refer to the WebShop User Guide.

4. The Save as type  box enables you to select the type of file your are creating, a WebShop
file or a WebShop template file.  For this exercise, select the WebShop Files  option.  This
produces a CNQ file.  To create a WebShop template, click on the drop-down arrow and
select WebShop Templates .  Templates are saved with a *.CTM extension.

5. When done, click Save.
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Adding New Pages

We will be adding two new pages to our test
site: one Free Page  and one Dynamic Page .
As you will see, WebShop comes with
different page types that you select when you
add a new page.

To add a Free Page

It is recommended that you create Free Pages
from the Site Manager–Logical Layout
window.  A Free Page created under the
Physical Layout will not appear in the
Logical Layout window.

1. Select the Site Manager–Logical
Layout tab and click the Home Page
icon to select it.

2. Select the Logical Layout > New Page
menu options or click the New button on the Logical Layout toolbar.  The Add Logical
Page dialog box appears.

Note:  This dialog box enables you to add new Web pages.  You can select one of four page
types. By default Plain Page is highlighted.
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3. Select Free Page  and click OK.  A Free Page  icon appears in the Site Manager–Logical
Layout  window with the default name “FreePage1” ready to be customized

4. Type “SurveyForm” and press ENTER to accept the new name.

To add a Dynamic Page

It is recommended that you create Dynamic Pages from the Site Manager–Logical Layout
window.  A Dynamic Page created under the Physical Layout will not appear in the Logical
Layout window.

1. From Site Manager–Logical Layout , select the SurveyFrom icon.

2. Select the Logical Layout > New Page  menu options or click the New button on the
Logical Layout toolbar.  The Add Logical Page  dialog box appears.

3. Select the Dynamic Page  icon and click OK.  A Dynamic Page appears in the Logical
Layout with the default name “DynPage1.”

4. Press ENTER to leave this logical name unchanged.

In the Site Manager–Physical Layout  window, WebShop identifies this Dynamic Page as
DynPage1.asp.  Logical Layout names and Physical File names are not the same.  Logical
names do not include extensions and can be entirely different from Physical names.  You will
be working with the Dynamic Page “DynPage1” later.

Working with Free Pages

WebShop’s Free Page feature makes it easier group images, text boxes and other objects
together on the same page.  You can freely drag and drop objects without line-by-line con-
straints of plain Web pages.  In conformance with the Cascading Style Sheet-1 Standard
(CSS1) a WebShop Free Page uses “absolute positioning” to provide a higher level of creativity
when dragging and dropping layered objects.

For your demonstration Web site, you will want to place a text box and a survey form on a Free
Page.  Use the Grid feature to help you place these objects on the page.  The survey form is used
to gather information about visitors to your Web site and will include a variety of form ele-
ments.

To set up the Grid and Snap to Grid features and insert a text box

1. From Site Manager–Logical Layout , double-click the SurveyForm  icon to open the
SurveyForm  window.

Note: The window naming convention for pages displayed in Page Editor is as follows:
<Logical Layout name> followed by <Physical File name>.  The Physical File name is
always in brackets.  For purposes of this manual, the Page Editor window will be identified
by the Logical Layout name.

2. Select the maximize button to maximize this SurveyForm  window.

3. Select the View > Grid menu option.  WebShop transforms the SurveyForm  window
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background by displaying a page layout grid.  Visitors will not see this grid once the page
is published.

4. Select the View > Snap to Grid  menu option.  Objects will now “snap” to the layout grid
when inserted or repositioned.

Note: When WebShop Preferences were covered, Frequency was set to 4 gridlines per inch.
This gives you detailed control over object placement.  The Snap to Grid feature automati-
cally places the edge of objects on the nearest grid line.

5. To add a text box to the free page, select the Object > Add > Text Box  menu option or
click the Text Box  button on the Insert Object toolbar.  A default Free Page text box
appears.

Note: WebShop considers this an “object.” Rectangular “handles” appear on the sides and
corners of the text box.  You may select and drag the text box anywhere on the Free Page.
To “turn off” the Snap to Grid controls select View > Snap to Grid .  The box frame only
appears when the text box is selected.  By default, the text box has inherited the same
background as the Free Page.

To customize the style of a single Free Page object

To provide a solid background color for this text box without changing the style of the entire
Free Page, follow these steps:

1. Double-click within the text box.  The handles shrink in size.  The layout grid in the text
box background is also hidden.
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Note: The flashing cursor indicates that the text box is in Edit mode.  While in Edit mode you
can add new content, edit existing content, or customize the style of the text box.

2. Select the Format > Background menu options.  The Page Style  dialog box appears.

Note: The Style section indicates that the text box has automatically “inherited” the
“BlueJeans” style that you assigned to the entire Web site when completing the procedure
“Changing Style Sets” (see Table of Contents).

3. Select the Specific Style  radio button in the Style  section and select the Default_Style
from the Specific Style  drop-down list.  This style carries a solid white background.

4. Click OK.  The SurveyForm  window reappears with “BlueJeans” still displayed as the
style for the page, but the text box now has a white background and remains in Edit mode.

To enter and format text for a Free Page text box

1. With the text box still in Edit mode, select the Center  button on the Formatting toolbar to
center the cursor in the text box.

2. Type “Tim’s Trains” and press ENTER to move the cursor down.

3. Type “Customer Satisfaction Survey” and press ENTER again to move the cursor down.

4. Highlight “Tim’s Trains ” and select Heading4 , H4 from the Style  menu on the Formatting
toolbar.  “Tim’s Trains” appears in the Heading4 , H4 style.

5. Highlight “Customer Satisfaction Survey ” and select Heading5 , H5 from the Formatting
toolbar.  The text displays the new style.  Press the DOWN ARROW once to move to the
next line.

Note: The text box remains in Edit mode.  If you are done editing, you exit Edit mode by
clicking once outside the text box.  For now, allow the text box to remain in Edit mode.

Creating Web Page Forms

For this test site, you will want to create a simple customer survey form for Tim, who wants to
set up a store on the Internet.  This form will demonstrate several different types of form
elements: Combo Boxes, Check Boxes, Text Lines, List Boxes and Text Boxes.  After building
a simple form, you will build a simple feedback page that makes the survey information come
to Tim’s email box.

Build your survey form using the same text box you just created.  To add form elements, you
must be in Insert Form mode.  To do this, open the Free Page that contains the text box and
double-click on the text box to open it.  You are now in Edit mode.  Select the Insert > Form
menu options or click the Insert Form  button from the Insert Objects toolbar.  You are now in
Insert Form mode.  Once in Insert Form mode, the Form Fields toolbar appears.  Click the
Show/Hide icon on the Standard toolbar to display the two lines that represent the form area.
All from contents must be within these two lines.
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To create a Combo Box form element

Tim wants you to set up this combo box as the response to survey question 1, which asks for the
visitor’s favorite scale model.  The combo box prompt will say “Choose One” and two options
are HO scale and O scale.  You must type in survey question 1 before inserting the combo box.
Make the option “Choose One” the default so that it can be a prompt.

1. With the text box in Edit mode, type “1) Your favorite scale models:” and press the
SPACEBAR  twice.

2. Select the Insert > Form Field >
Combo Box  menu options or click the
Combo Box  button on the Form Fields
toolbar.  The Combo Box Properties
dialog box appears.

Note:  This dialog box is used to name
the combo box object and specify the
items to its display in the combo box list.

3. In the Name input line, type “Favor-
iteScale”

4. Double-click Item1 in the Items section.
The Item Properties  dialog box
appears.

Note:  This dialog box is used to specify
an item label and an item value for each
selectable option.

5. Type “Choose One” in the Item Label input line and press TAB .

6. Type the numeral “0” in the Item Value input line and click OK.  The Combo Box Proper-
ties  dialog box reappears.

7. Double-click Item2 in the Items section.  The Item Properties  dialog box appears.

8. Type “HO Scale” in the Item Label input line and press TAB .

9. Type the numeral “1” in the Item Value input line and click OK.  The Combo Box Proper-
ties  dialog box reappears.

10. Select Add Item .  The Item Properties  dialog box appears.

11. Type “O Scale” in the Item Label input line and press TAB .

12. Type the numeral “2” in the Item Value input line, and click OK.  The Combo Box
Properties  dialog box reappears.

Note:  The text box now contains your first survey question and form element, a Combo Box.
This form element is set up with one prompting item and two selectable items.

13. Click on the check box for the item Choose One  to make this the initially selected default.

14. When done, click OK.  The SurveyForm  window reappears.
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The combo box is placed next to the survey question and the cursor is to the right of the combo
box.  The window is still in Insert Form mode.

To create a Radio Button form element

Tim wants you to set up some radio buttons that allow visitors to respond to survey question 2,
which asks “Do you collect rare model train pieces?” To create this part of the survey, insert
three radio button form elements.  Each of these radio buttons will have the same radio button
name, “RareModelPieces.” By assigning the same name, only one radio button can be selected.
Use the labels “Yes, Often,” “Occasionally,” and “Well, No.” Make the option “Yes, Often” the
default.

1. Still in Insert Form mode, press ENTER to move to the next line.

2. Type “2)  Do you collect rare model train pieces? (Check one box only please)” and
press SHIFT + ENTER to create a soft line return.

Note:  A hard line return is a paragraph break, a soft line return keeps text and form
elements together in the same paragraph.

3. Select the Insert > Form Field > Radio
Button  menu options or click the Radio
Button  icon on the Form Fields toolbar.
The Radio Button Properties  dialog
box appears.

Note: This dialog box is used to specify
the object name and value.

4. Type “RareModelPieces” in the Name input line and press TAB  to move to the Value
field.

5. Type the numeral “1” in the Value  input line and click OK.  The SurveyForm  window
reappears.  The radio button appears on the form, however there is no label.

6. Press the SPACEBAR once, type “Yes, Often” and press the SPACEBAR twice to position
the next radio button.

7. Repeat Steps 3–6 twice to create two additional radio buttons with the labels “Occasion-
ally” and “Well, No” and with the values “2” and “3” respectively.  All of these will have
the same object name “RareModelPieces.”

8. When done, click OK.  The SurveyForm  window reappears.

All radio buttons and labels are displayed and the cursor is to the right of the last radio button
label.  The window is still in Insert Form mode.

To create a Text Line form element

Tim wants you to set up a text line element that allows visitors to response to survey question 3,
which asks for the visitor’s favorite model manufacturer.  This will be an open-ended response.
The text box will store the visitor’s answer just as it is typed.  To create this part of the survey,
insert a text line next to the survey question and use the prompt “Type answer here.” Specify a
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text box that is 23 characters long and only holds 23 characters of text.  By using the prompt
“Type answer here” you have assigned a default value.

1. Still in Insert Form mode, press ENTER to move to the next line.

2. Type “3)  Your favorite model manufacturer:” and press the SPACEBAR  twice.

3. Select the Insert > Form Field > Text
Line  menu option or click the Text Line
button on the Form Tools toolbar.  The
Text Line Properties  dialog box
appears.

Note:  This dialog box is used to specify
the object name, value, field size,
maximum text length.

4. Type “Manufacturer” in the Name
input line and press TAB .

5. Type “Type answer here” in the Value  input line and press TAB .

6. Type the numeral “23” in the Field Size input line and press TAB .

7. Type the numeral “23” in the Text Max Length input line and click OK.  The SurveyForm
window reappears.

The text line with the prompt “Type answer here” is displayed next to the survey question and
the cursor is to the right of text line box.  The window is still in Insert Form mode.

To create a List Box form element

A List Box enables your visitors to pick from a visible list of one or more options.  If you wish,
more than one option to be selected.  In this case, Tim is asking visitors to make a single choice
from four visible options.  Make the option “Frequently” the default.

1. Still in Insert Form mode, press ENTER
to move to the next line.

2. Type “4)  Have you purchased
products on the Internet?” and press
the SPACEBAR  twice.

3. Select Insert > Form Field > List Box
or select the List Box  button from the
Form Fields toolbar.  The List Box
Properties  dialog box appears.

Note: This dialog box is used to name
the list box object, specify the number of
visible items, and define the selection
items.

4. Type “OnlineBuying” in the Name
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input line and press TAB .

5. Type the numeral “4” in the Number of Visible Items  input line and press TAB .

6. Leave the Allow Multiple selection  check box unchecked.

7. Double-click Item1 in the Items section.  The Item Properties  dialog box appears.

Note:  This dialog box is used to specify an item label and an item value for each selectable
option.

8. Type “Frequently” in the Item Label input line and press TAB .

9. Type the numeral “1” in the Item Value input line and click OK.  The List Box Properties
dialog box reappears.

10. Select Item2 and click Remove Item .  The warning message Are you sure you want to
delete this item? appears.  Click Yes.

11. Repeat Steps 7–8 three times using Add Item  to create three list box items.  Use the
following item labels and values, respectively: “Occasionally” (2), “Once or Twice” (3);
and “Not Yet” (4).

12. Click on the check box for the item Frequently to make this the initially selected default.

13. When done, click OK.  The SurveyForm  window reappears.

The list box with four selectable items is displayed next to the survey question and the cursor is
to the right of list box.  The window is still in Insert Form mode.  As displayed, your list box
has a scroll bar.  When the published, this scroll bar disappears.

To create a Text Box form element

Unlike a text line, a text box enables your visitors to supply free-form responses without any
size restrictions.  In this case, Tim is asking visitors to type comments into a text box that has
the opening salutation, “Hello Tim.” By entering the salutation “Hello Tim,” you have assigned
a default value.

1. Still in Insert Form mode, press ENTER to move to the next line.

2. Type “5)  Please feel free to add an
additional comment or suggestion:”
and press the SPACEBAR  twice.

3. Select Insert > Form Field > Text Box
or select the Text Box  button from the
Form Tools toolbar.  The Text Box
Properties  dialog box appears.

Note:  This dialog box is used to specify
the object name, default value, horizon-
tal size, and vertical size.  The size
specifications are for form display
purposes only.

4. Type “Comments” in the Name input
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line and press TAB .

5. Type “Hello Tim,” in Default Text (Value) input box and press TAB .

6. Type the numeral “47” in the Horizontal Size  field to make the text box 47 characters
wide.  Press TAB .

7. Type the numeral “4” in the Vertical Size  field to create a text box 4 lines long and click
OK.

The SurveyForm  window reappears in Insert Form mode.  A text box 47 characters wide and 4
lines tall is displayed.  “Hello Tim ,” is default text.

To create another Text Line form element

Tim wants you to set up another text line element that allows visitors to response to survey
question 6, which asks for the visitor’s email address.  To create this part of the survey, insert a
text line next to the survey question and use the prompt “Type address here.” Specify a text box
that is 23 characters long and only holds 23 characters of text.

1. Still in Insert Form mode, press ENTER to move to the next line.

2. Type “6)  Your E-mail address:” and press the SPACEBAR  twice.

3. Select the Insert > Form Field > Text Line  menu option or click the Text Line  button on
the Form Tools toolbar.  The Text Line Properties  dialog box appears.

4. Type “Email” in the Name input line and press TAB .

5. Type “Type address here” in the Value  input line and press TAB .

6. Type the numeral “23” in the Field Size input line and press TAB .

7. Type the numeral “23” in the Text Max Length input line and click OK.  The SurveyForm
window reappears.

The text line with the prompt “Type address here” is displayed next to the survey question and
the cursor is to the right of text line box.  The window is still in Insert Form mode.

To create a Clear Push Button element

A Clear  push button allows your Web site visitors to erase their survey responses before
submitting them.  In this case, Tim wants to
center the push button at the bottom of the
survey form.

1. Still in Insert Form mode, press ENTER
to move to the next line and click the
Center button on the Formatting toolbar
to center the cursor in the text box.

2. Select Insert > Form Field > Push
Button  on the Main toolbar or select the
Push Button icon  from the Form Fields
toolbar.  The Push Button Properties  dialog box appears.

Note:  This dialog box  specifies the object name, the button label, and the button type.
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3. Type “Clear” in the Name input line and press TAB .

4. Type “Start Over” in the Value (Label)  input line.

5. Click the Reset  radio button in the Button Type  section and click OK.  The SurveyForm
window reappears.

A push button with the button label “Start Over ” is displayed.  When visitors click on it, the
survey form is reset.

To create a Submit Push Button element

When the visitor has completed the survey, you will want to gather the information for process-
ing.  This is done by creating a Submit  push button.

1. Still in Insert Form mode, press the SPACEBAR  twice to add space between the two
buttons.

2. Select Insert > Form Field > Push Button  or select the Push Button  icon on the Form
Fields toolbar.  The Push Button Properties  dialog box appears.

3. Type “Submit” in the Name input line and press TAB .

3. Type “Send It In” in the Value (Label)  input line.

4. Click the Submit  radio button in the Button Type  section and click OK.  The SurveyForm
window reappears.

A push button with the button label “Send It In ” is displayed.  When visitors click on it, the
survey form is submitted.

This completes the work on the survey form.  To view it from your default browser, select File
> Preview in Browser  or select the Preview button from the Main toolbar.  You should see the
following in your browser:
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Linking the Survey Form Free Page to the Dynamic Page
To make the survey form useful, WebShop needs you to point to the Dynamic Page where the
visitors’ form input will be sent for processing.  To do this you must be in Form Insert mode.
To return to Form Insert mode, open the Free Page that contains the text box and double-click
on the text box to open it.  You are now in Edit mode.  If the text box contains a form, place
your cursor in the form area and you are automatically placed in Form Insert mode.

To link the survey form to a dynamic page

1. Still in Insert Form mode, right-click on some white space inside the text box form.  A pop-
up menu appears.

2. Select Form .  The Form Properties  dialog box appears.

Note: This dialog box is used to specify the action that is associated with the form elements
you have placed in the text box. It has a number of different sections. At this point, you are
concerned only with the Action section.

3. Click Local radio button in the Action section.  The Physical Layout display area becomes
active.

4. Double-click the CGI_Bin  folder and select “DynPage1 .asp .”

Note:  By creating the Dynamic Page, DynPage1, in Logical Layout, the physical resource
associated with this page, DynPage1.asp, was automatically stored in the CGI_Bin folder.

5. When done, click OK.  The SurveyForm  window reappears.

6. Click on some blank area outside the text box to close the text box and to exit Insert Form
mode.

7. Close the SurveyForm  window to return to Site Manager–Logical Layout .

After Tim’s test Web site is uploaded to the Internet and once a visitor submits a valid survey,
all input from the survey form will be directed to the Dynamic Page, DynPage1.asp, for
processing.  Your survey form will not work until the Dynamic Page is built and uploaded to a
server.  You should save your work before continuing.

Working With Dynamic Pages

WebShop employs the power of Active Server Pages (ASP) to enable the non-programmer to
create forms, collect data from Web site visitors and have that data processed for delivery via
email.  The ASP technology used in WebShop adopts the ASP standard developed by Microsoft
and requires that your Web site be hosted on a Web-server using one of the following system
platforms:

• Windows NT running Internet Information Server (IIS)

• Windows 95 running the Peer Web Server

• Unix, Sun Solaris, Netscape or other Web Server systems which are 100% compatible with
ASP technology.



WebShop 29

Quick Start Guide

Sending an email generated from Web site form has traditionally been problematic due to errors
in the use of CGI scripts through an SMTP server.  To solve this problem, Boomerang has
developed an Active-X  component that will contact the Mail server and send the mail without
error.

Active-X Component Registration

An Active-X component is a *.DLL file that resides in the Web server’s System folder.  Web-
Shop comes with a proprietary Active-X component called Send-MAX (short for “Send Mail
Active-X).  To successfully run your E-commerce Web site, Send-MAX must be registered on
your hosting company’s Windows NT-server.  Send-MAX automatically generates email
confirmations for you and your customers once a buy transaction is complete. To register Send-
MAX, contact your Web-hosting / ISP provider and ask them to register the Boomerang
Software Active-X component called Send-MAX.  For them to register Send-MAX, you will
need to send them the contents of the folder located on the WebShop program CD X:\Server
Components\Send Mail  (where X designates your CD ROM drive).

The Send Mail  folder contains the following files:

••••• MailX .dll

••••• Readme .txt

••••• Reg.bat

••••• Unreg .bat

Once you have confirmed the contents of this folder, you will want to do the following:

1.  Copy the Send Mail  folder and place it on your hard disk.

2.  Send your Web-hosting/ISP provider the folder by email and ask them to run the batch file
Reg.bat  or upload your site (including the above files) and ask them to test Send MAX.

Be sure that your Web-host administrator reads the Readme text file before attempting to
register Send MAX.  Your Web Site/ISP provider can unregister Send MAX by running the
batch file Unreg .bat .  Send MAX has been fully tested on Windows NT-servers Running IIS.  If
there are any questions, from the Web Site/ISP provider, regarding the registration of the
Active-X component, Send MAX, have them call the Boomerang Software Technical Support
Department at (617) 484-4664 or email Boomerang Software, Inc. at either of the following
email addresses:

• techsupport@boomerangsoftware.com

• webhostingsupport@boomerangsoftware.com

LEGAL NOTICE: The Active-X program and associated program files provided on the CD are
COPYRIGHTED properties belonging to Boomerang Software, Inc., with all rights reserved.  You
and your ISP or Web Hosting provider may use these software products FREE OF CHARGE,
with proper acknowledgment to Boomerang Software.  These software products may not be sold
or distributed in any manner without the written permission from Boomerang Software, Inc.
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Dynamic Page Display

To open a dynamic page, select Site Manager–Logical Layout  and double-click the DynPage1
icon.

When first opened, a Dynamic Page has two visible parts: A Dynamic Page Manager window,
which displays a ROOT icon; and Dynamic Page “editor” window, which when empty displays
a crosshatch pattern.  For simple operations you will only need these two window displays.  If
you choose to assign frames to the dynamic page, you will also want to open the Frame Man-
ager window.  To do this, click the Frame Manager  button on the Frames and Page Editor
toolbar.  The Frame Manager window displays the Frame resources currently applied.  These
resources are called Frame-Content Overlays and are associated with entire pages or with
individual frames on a page.  For more information about frames, see the chapter titled “Web-
Shop Frames” in the WebShop User Guide.

Dynamic Page Operations

For purposes of this manual, we are only concerned with generating a Dynamic Page that takes
the survey information and creates two kinds of feedback: an error condition feedback that asks
the visitor to fill in fields that are missing and a success feedback that thanks the visitor for
completing the survey.  Once the survey results are successfully evaluated then the survey data
must be sent via email to the Tim who will then respond to each respondent as he wishes.  To
accomplish this the following dynamic page operations must be completed:

• Assigning parameter names .  Dynamic operations are build around parameters that
reference existing objects that have a specified value.  In this operation, you will be
creating parameters that reference back to each of the survey form objects.  You will
remember, each object or selectable item has a specified value.  By assigning parameter
names, these object values become available for evaluation.  The survey form objects that
you have already created and which require a parameter name are as follows: “FavoriteS-
cale” (combo box); “RareModelPieces” (radio buttons); “Manufacturer” (text line);
“OnlineBuying” (list box); “Comments” (text box); “Email” (text line).  You do not need to
set up the “Clear” and “Submit” (Push Buttons) as parameters.
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• Defining variables .  Variables are used to hold temporary values that are generated by a
Dynamic Page operation.  These variables can then be used to make condition evaluations.
By defining the variables that will be used in one or more operations you make them
available for use with your dynamic page.  For Tim’s survey, you will be defining the
variable “var_any_error.” This variable will be used to determine whether or not the visitor
entered values into the survey fields.  If the customer failed to enter a value, then the
variable will accumulate a value that will be displayed to the visitor so that he / she can
correct their survey and resubmit it.  This variable will use the operation called CONCAT-
ENATE—to concatenate means “to join to.” This operation will allow the variable to
accumulate error information by successively joining error text together before sending it
back to the visitor.

• Setting up an “IF” condition .  An “If” condition is a test that is applied to one or more of
the parameters and variables assigned to a Dynamic Page.  The construction of an “If”
condition has three parts: If–Then–Else.  The first part is a simple evaluation of a parameter
or variable against a specifically assigned value.  This part generates either a true or false
result.  The Then–Else parts are both action statements used to complete an operation.  The
“Then” condition assigns and operation to a True result; the “Else” condition assigns an
operation to the False result.  The icons associated with an “If” condition include the “IF”
statement icon, the “OK” statement icon and the “NO” statement icon.  The “IF” statement
icon is associated with the “If” condition.  The “OK” statement icon is associated with the
“Then” condition.  The “NO” statement icon is associated with the “Else” condition.

For Tim’s survey, you will be evaluating each of the parameters setup in the Customer
Survey to insure that the default values have been changed.  The default values assigned to
each parameter on the survey form were as follows: “FavoriteScale” (combo box; default
0–Choose One); “RareModelPieces” (radio buttons; default 1–Yes, Often); “Manufacturer”
(text line; default ‘Type answer here’); “OnlineBuying” (list box; default 1–Frequently);
“Email” (text line; default ‘Type address here’).  The “IF” condition for each of these
parameters will evaluate to see if the default value still remains.  If so, then an error
message will be created.  You will not be evaluating the “Comments” (text box; default
‘Hello Tim’) since Tim will not be evaluating this field for completion.  Therefore, you will
not be creating an “If” condition to evaluate this parameter.

• Creating an “OK” statement .  By creating an “OK” statement you are creating an action
statement that assigns an operation to a true result.  For Tim’s survey, the OK statement
will be responding to those instances where the visitor has failed to enter information (that
is, the default values are the current values).  To generate a result that can be Feedback to
the visitor, you will need to “add into” the OK statement; a Statement element that will
allow you to accumulate error text that can be displayed.

• Creating Feedback Sections .  Feedback sections are conditional Web pages that display
only under certain conditions.  For Tim’s Survey, you will be creating a Success Page and
an Error Page.  The Success page will display the message, “Thanks for filling out our
customer satisfaction survey! Your comments have been sent to Tim.” The Error page will
display the message “You have not entered the following fields:” along with the current
value of “var_any_error.”
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• Creating a Send Mail operation .  The send mail operation enables you to take parameter
results send them over the internet (via email) to another person.  For Tim’s survey, this
operation will happen after the survey has been successfully evaluated and the Success
page feedback has been sent.  Therefore, the Send Mail operation must be added into the
same condition that generated the Success page feedback.

Setting Up Dynamic Page Functions

To open a dynamic page, select Site Manager–Logical Layout  and double-click the DynPage1
icon.  The DynPage1 window appears.  Using the Dynamic Page Manager window and the
Dynamic Page “editor” window, you perform the necessary procedures required to create a
Dynamic Page that receives a visitor’s survey response upon clicking the Send It In  button.
This dynamic page will evaluate the survey for completion, provide conditional feedback, and
upon successful submission send an email to Tim with the visitor’s responses.

Assigning Parameter Names
For each of the form field names we assigned in the survey form, we need to assign a parameter
name.  These parameter names will be used by WebShop to process Send Mail.  Follow these
steps to set up parameter names:

1. Double-click the ROOT icon.  The Property Sheet for Dynamic Pages dialog box
appears.

Note:  This dialog box defines parameters, variables and cookies to the Dynamic Page.  To
apply an operation to any one of Tim’s Survey fields, the field must be assigned an input
parameter name.

2. Select the Input Parameters  tab and type in the New Parameter  input line the field names
from the form.  Type “FavoriteScale” for Tim’s survey item number 1 and click Add .

3. Repeat Step 2 for each customer survey form field: “Manufacturer,” “OnlineBuying,” and
so on, until all form field elements have been assigned Input Parameter names.

Defining a Variable
Because we are requiring all visitors who want to submit a survey to complete every field
except the comments section, we need a simple error message to appear when a visitor attempts
to submit a survey with one of the required fields left blank.  This means you need to create an
“error” variable.

To define a variable

1. With the Dynamic Page, DynPage1 .asp , open, double-click on the ROOT icon.  The
Property Sheet for Dynamic Page  dialog box appears.

2. Select the Variables  tab.



WebShop 33

Quick Start Guide

3. Type into the New Variable  input line “var_any_error” which is the name of our “error
variable” and select Add .  The variable var_any_error  now appears in the Variables List
box.

4. Select OK.  We will use this variable if any required survey fields are submitted empty or
not selected.

Setting up an “IF” Condition
For the error variable to succeed, we need to set up and run a simple “IF” condition test each
time a visitor clicks on “Send It In .” We already assigned each survey form field a parameter
name.  If a condition exists in which a survey field is not filled out or entered but that survey is
submitted, then we will assign the field parameter a name and the variable “var_any_error ” a
value.

To set up an IF condition

1. Highlight ROOT and right-click.  A pop-up menu appears.

2. Select Add Into > Condition .  An “IF,” “ OK,” and “NO” set of icons appears.  The “IF”
icon is titled “Empty Condition .” In this procedure you will be concerned only with this
icon.

3. Repeat Steps 1–2 five times.  You will be creating a condition to test each of the survey
fields for completion.  When done, five sets of condition icons should appear in the
Dynamic Page Manager  window.

4. Double-click the first “IF” statement icon.  The Set Conditions  dialog box appears.

Note:  This dialog box defines the evaluation that you want to perform.  It has three parts, a
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left operand, an operation, and a right operand.  An operand is a value that is subject to an
operation, most often these will be either parameters or variables.

5. Select the Parameters  tab on the left side operand, and click to open the drop-down list
box.  All of the parameters you assigned above should be listed.  Select “FavoriteScale ”
and press TAB .

6. For Operation  use the drop-down list box, select “Equal ,” and press TAB .

7. For the right operand, select the Value  tab and type the numeral “0” which is the default
value we assigned to the item “Choose One .” See the procedure titled “To create a combo
box form element” in the Working with Forms  section above.

You have just set up a condition which specifically looks for and identifies the default value.
The presence of that condition will trigger an error page which is defined by the variable
“var_any_error .” Click OK.

In plain English, those visitors to Tim’s Web site who want to submit a customer survey will be
required to pick a model train scale as their “favorite.” The default prompt item “Choose One ”
will not be accepted by the Web-server because “Choose One ” has a default value of zero.
Since all of the other model scale choices have a value other  than zero, the default Choose One
is the only  choice that will trigger the error the condition.

Now, repeat Steps 4–7 four more times to create an “IF” condition that tests for the default
values for each of the survey form’s elements.  You do not need to create an “IF ”condition for
the parameter “Comments .” Tim is not requiring this field to be completed.

When done, the following “If ”condition statements should display:

IF Parameter[ “FavoriteScale ” ]=0
IF Parameter[ “RareModelPieces ” ]=1
IF Parameter[ “Manufacturer ” ]=‘Type answer here’
IF Parameter[ “OnlineBuying ” ]=1
IF Parameter[ “Email ” ]=‘Type address here’
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Creating an OK Statement
After creating an “IF” condition which identifies the presence of a parameters default value you
now must generate an “OK” statement which will assign the variable, “var_any_error ” a value
that will let visitor’s know that they have not completed the form.  If the customer fails to
answer a question, then this variable accumulates a value (as a message) that is displayed to the
visitor, who then will correct and resubmit the survey.  This variable uses the operation,
concatenate—which means “to join to.” This operation enables the variable to accumulate error
information by successively joining error text together before sending it back to the visitor on
the Error page.

To create an OK statement

1. With the DynaPage1  window still open, select the “OK” icon and right-click.  Select Add
Into > Statement .

2. Double-click the Statement  icon.  The Set Variable To  dialog box appears.

Note: This dialog box defines the value that you want to assign to the variable.  It has three
parts, a left operand which is always a variable, an operation, and a right operand.

3. In the Choose Variable Name  section select “var_any_error .”

4. Select the center operand drop-down arrow.  From the drop-down list box, select Concat-
enate .

5. Select the Value  tab in the right operand.  Type “FavoriteScale,” in the Insert Value  input
line.  Be sure to add a “, ” (comma and space) after the last “e” in “FavoriteScale .” Click
OK.

6. Repeat this procedure for the other required form fields, using “var_any_error ” for the
Choose Variable Name and Concatenate  for the center operand and under the Value  tab
in the right side operand, typing in the respective parameter names for the other required
form fields: “RareModelPieces,” “Manufacturer,” “OnlineBuying,” and “Email.”

When done, the “OK” statement  will have a sub-statement, with a Statement icon that assigns
the variable, “var_any_error,” the following value:

OK Then
S Variable[ “var_any_error ” ] CONCATENATE WITH  “parameter, ”

where “parameter, ” represents the respective form fields required.

Setting up the Feedback Page Condition
You must now set up the feedback condition that will deliver feedback to the visitor and send
out Tim’s email with the survey results.  This condition will evaluate the variable,
“var_any_error,” to see if there is any data in it.  If so, then an error message must be sent.  If
not, then a success message must be sent.  Since the success message confirms that the survey
was correctly completed, you will also want to set up the Send Mail operation within the same
condition that evaluates the variable, “var_any_error” for data.
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To set up the feedback page condition

1. With the DynaPage1  window still open, highlight the ROOT icon, right-click and select
Add Into > Condition .

2. Double-click the “IF” statement.  The Set Condition  dialog box appears.

3. For the left operand, select the Variable  tab and select the variable “var_any_error .”

4. For the operation, select “Not Equal .”

5. For the right operand, select the Value  tab and leave the input line blank.  Click OK.  The
DynPage1  window reappears,

When done, the following “If ”condition statement should display:

IF Variable[ “var_any_error ” ] < >
OK Then
No Else

This condition sums up everything we have done in the Working With Dynamic Pages  section.
It says that “IF” the condition variable “var_any_error ” contains information (that is, not equal
to <empty string>) then “OK”– an error message will be sent (this message is not yet specified),
or “NO”– an success message will be sent (this message also is not yet specified).

Creating an Error Page
Tim wants you to create some feedback that tells the visitor which fields have not been com-
peted.  You will want the feedback to be delivered once, after all of the survey fields have been
evaluated.  The variable, “var_any_error,” has accumulated the names of each field that must be
completed before the survey can be successfully submitted.

To create an error page

1. Click the “OK” statement icon.  Right-click and select Add Into > Feedback Section .
Beneath the “OK” statement icon, a Feedback Section  icon appears.
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2. Select the Feedback Section  icon and
double-click.  The Feedback Section
dialog box appears.

Note: This dialog box assigns the
Feedback Section a name.

3. In the Feedback Section Name  input
line, delete Feedback Section , type “Error” and click OK.

4. Click once in the right-side work space window.

Note: You are now in the Page Editor for the Feedback Page you just created.  By default,
this is a Plain Page.

5. Type “You have not entered the
following fields:” and press ENTER.

6. Select Dynamic Page > Insert Dy-
namic Element  menu option or select
the Insert Dynamic Element  button on
the Dynamic Page toolbar.  The
Dynamic Text Element  dialog box
appears.

Note: This dialog box lists the param-
eters and variables that can be inserted
onto a Feedback Section.

7. Highlight “var_any_error ” and double-
click.  The shaded variable
var_any_error instantly appears in the
right window.  This shaded phrase
represents the concatenated phrase
which includes the names of any survey
fields that still contain the default value.

8. Click on the Windows Close button to close the Dynamic Text Elements  dialog box.

An Error page with a custom “message” has been created.  It will only display when any one of
the evaluated survey fields has not completed.

Creating a Success Page
You created a Feedback page from the “OK”  condition and named it Error .  Now, you must
create a Success  page for the “NO” condition.  This feedback page will have a thank-you
message indicating that the survey was successfully submitted.

To create a success page

1. Click the “NO” statement icon.  Right-click and select Add Into > Feedback Section .
Beneath the “NO” statement icon, a Feedback Section  icon appears.



38 WebShop

Quick Start Guide

2. Select the Feedback Section  icon and double-click.  The Feedback Section  dialog box
appears.

3. In the Feedback Section Name  input line, delete Feedback Section , type “Success” and
click OK.

4. Click once in the right-side work space window and type, “Thanks for filling out our
customer satisfaction survey!  Your comments have been sent to Tim.”

An Success page with a custom “message” has been created.  It will only display when all of the
evaluated survey fields have been completed.

Creating a Send Mail operation
Once the success page has been displayed to the visitor, Tim wants that visitors responses sent
to him via email.  You must now insert the Mail To operation and compose the email message
that reports the survey responses to Tim.

To create a Send Mail operation

1. Click the “NO” statement icon that contains the Success  feedback page.  Right-click and
select Add Into > Send Mail .  The Send Mail  icon appears beneath the Success  page icon.

2. Double-click on the Send Mail  icon.  The Send Mail Property Dialog box appears.

Note: This dialog box specifies how the email will be sent.  It contains the fields From:, To:,
CC:, Subject, SMTP server, and Attachment.  The two critical fields that must be filled out
every time are To: and SMTP Server.

4. In the From:  section, select the Parameters  tab.  From the drop-down list box select the
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Email  parameter.  This places the Email address from the Email form field into the From
section in the Header of the email Tim will receive.  So Tim can reply directly if he desires
to each survey respondent.

5. In the To:  section, select the Value  tab.  Type the email address where the results of each
survey submission should be sent.  In this case, we would type Tim’s Email address:
“ tim@timstrains.com”

6. In the Subject:  box enter what you want to be displayed in the Subject Box of the Email
sent to Tim.  In this case, the Subject is, “Tim’s Trains Customer Survey.” You could even
have the Subject set up as choices in a form field and have it dynamically posted.

7. In the SMTP server  field, type in the name of the mail server where the Web site is hosted.

Note: A mail server name usually resembles something like, “mail.mailserver.com” or an “IP
address” which is usually four numerals separated by decimals.  In this case, based on the
IP address depicted, we are assuming that “timstrains.com” is hosted by Boomerang
Software, Inc.

8. When done, click OK.

You have now set up the specifications for sending an email to Tim.  However, you have not
specified the format for sending this information.  To do this you will need to create some
dynamic text that will display the visitor’s survey responses.

Creating Dynamic Text for a Mail to Operation
Tim wants the survey responses sent to him is as close a form as possible to the survey itself.
Right now some of the survey responses are identified by a value that corresponds to a radio
button label or selection item.  Tim wants to receive these numerical values (rather than the
label text) since he is going to analyze the survey results arithmetically.

To create dynamic text for an Mail to operation

1. Highlight the Send Mail  icon.  Click
once in the right-side work space
window.

2. Type “Customer Survey Results”
and press ENTER.

3. Type “1.  Favorite Model Train
Scale:” and press the SPACEBAR .

4. Select Dynamic Page > Dynamic
Element Insertion  or select the
Dynamic Element Insertion  button on
the Main toolbar.

5. In the Parameters  section select
“FavoriteScale ” and double-click.  A
shaded Parameter( “FavoriteScale ” )
icon appears.  Press ENTER.
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6. Repeat Steps 3–5 for each of the survey form questions and associated parameters, Ques-
tion 2–“RareModelPieces,” Question 3–“Manufacturer,” Question 4– “OnlineBuying,”
Question 5–“Comments,” and Question 6–“Email.” When all six survey questions have
been accounted for, and dynamic text has been associated with each has been inserted,
click the Windows Close button to close the Dynamic Text Elements dialog box.

7. Click the Save button to save your work.  Your demonstration Web site is complete!

Note:  When constructing a form for use with a Dynamic Page, it is recommended that you
assign a default value to every parameter.  While assigning a parameter a default value of
<empty string> is possible, this default does not provide a developer with much test informa-
tion.  Once your site has been tested, then you might consider resetting those defaults,
associated with those survey questions that do not  have an invalid  option. For Tim’s survey,
this would include questions 2 and 3.

To summarize, you have created a Web site with a Home Page, a Survey Page and a Dynamic
Page that evaluates a visitor’s survey responses and sends survey results to Tim via Email.

The Dynamic Page tests to see if the survey form’s defaults have changed to determine if the
survey was completed by the visitor.  If so, a Success Page is displayed.  If not, an Error page is
displayed.

Although this step-by-step process may seem tedious, consider this—WebShop provides a very
powerful set of tools that will allow you to set up intricate form fields and employ Send Mail
just like the professionals—even if you are an absolute non-programmer.

These step-by-step tutorials are designed to give even a nervous new Webmaster a solid
opportunity to deploy some of the latest Internet technology.

You are now ready to upload your demonstration Web site to a World Wide Web-server and try
it out!  In the following sections, you will be introduced to additional WebShop features which
you can use to create unique Web pages that do what you want.
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Working with WebShop Features

Introduction

In this section we will be introducing some additional features that you may want to use.  Some
will continue with Tim’s Trains scenario, but most do not.

Creating Tables

Inserting Tables in a New Free Page
1. In Site Manager–Logical Layout , select the Home Page  icon.

2. Select the Logical Layout > New Page
menu option or click the New button on
the Logical Layout toolbar.  The Add
Logical Page dialog box appears.

3. Select Free Page  and click OK.  A Free
Page icon appears in the Site Man-
ager–Logical Layout window with the
default page name ready to be custom-
ized

4. Type “Announcing” and press ENTER.

Double-click the “Announcing ” page icon
to open the Free Page  window.  Maximize
the Free Page workspace.  The table for Tim
will announce Tim’s Customer Appreciation
Days.  A table on a Free Page needs a text
box to contain it.  Follow these steps to build
a table:

1. Select the Object > Add > Text Box or
click the Insert Text Box  button from
the New Object toolbar.  The new text
box appears, inheriting the default style background.

2. Double-click the text box.  The text box handles shrink as the text box enters Edit mode.
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3. Select Table > Insert Table  on the main menu or click the Table button on the Insert
Object toolbar.  The Table Properties  dialog box appears.

4. In the Cells  section, type the numeral “5” for Number of Rows  and press TAB .  Type the
numeral “2” for Number of Columns .  As Tim will not need a header or footer, TAB  to the
Sizes  section.

5. For Border Size , type the numeral “4” and press TAB .  For Cell Padding , type the numeral
“3” and press TAB .  For Cell Spacing , type the numeral “3” and TAB  to the Caption
section.

6. Select the Create  check box, select the Top  radio button and TAB  to the Alignment
section.

7. Select the Center  radio button.  Press OK.  The new table appears in the text box with the
cursor flashing.

The cells of the table show a default width of 1 character.  The new table automatically inherits
the default background style of the text box.  The text box background can be customized to
accommodate the new table.  Follow these steps to fill the table with content:

1. Click once to place the cursor in the empty caption section.  Select  Heading , H5 from the
Style  drop-down menu on the Formatting toolbar.  Type “Announcing”

2. Click once to place the cursor in the top-left cell of the new table.  Type “Who?” and press
RIGHT ARROW.  The cursor appears in the top right cell.

3. Type “Tim’s Trains” and press RIGHT ARROW.  The cursor moves to the next row.

4. Repeat Step 3 until all text is entered and the table is constructed as depicted.
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Modifying Individual Table Cells
Each table cell may be customized for background, text attributes, cell height, etc.  The caption
may also be customized.  The caption of
Tim’s table will have a custom background
color.  Follow these steps to customize a
table cell or a table caption:

1. With the table in Edit mode, click to
place the cursor in the caption.  Select
the Table > Cell Properties  option on
the main menu.  The Cell Properties
dialog box appears.

2. In the Background  section, click to
remove the Transparent  check mark.
Select the color bar icon on the right.
The Choose Color  dialog box appears.

3. Select a light blue shade and click OK.
The caption displays “Announcing ”
with a light blue background.

4. Repeat Steps 1–3 to customize the
background color of any individual table cell.

Importing Graphic Images

WebShop easily imports graphic images into Web pages.  You can also insert a graphic and text
into a table within a Web page so that a formatted system of rows and columns will display your
images.

To demonstrate this feature, build a table with 2 rows and 2 columns (no headers or footer
rows) below the table previously described.  Follow these steps:

1. Click twice inside the first cell (upper left corner of the table) to place the cursor in the cell.
Type “Meet Tim.”

2. Select the Insert > Image  menu option or click the Insert Image  button on the Insert
Objects toolbar.  The Image Library loads and the Image Attributes  dialog box appears.

3. In the Image Resources  section, select Import .  The Import  dialog box appears.

4. In the Look in  section, use the drop-down arrow to open the list of drives or other available
resources.  Here you would browse to the drive or directory where you can access a photo
of Tim.

5. Click once on each file being considered for import and the WebShop preview.  In the
Preview section of the Import  dialog box, place a check mark to enable immediate pre-
viewing of each file before you physically import the image.  Pick an image to represent
“Tim”
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6. Click OK.  The previewed image is imported into the cell.

7. In the Alternate Text  box, remove the “Image” text and type “Photo of Tim”

8. Click OK to import the image as a resource.

Creating Bookmarks

You can insert a Bookmark reference anywhere in a page or frame.  When you link to a
bookmark, the browser will go to that point in the page and display it at the top of the Browser
window.

1. If the Home Page  is not open, double-click the Home Page  icon to open it.

2. Press the END key to move the cursor to the end of the page.

3. Press ENTER to move the cursor to a new line.

3. Type “Important Events”

4. Highlight the text, “Important Events .”

5. Select the Insert > Bookmark  menu option or click the Bookmark button on the Insert
Objects toolbar.

6. In the Bookmark Name  text box, type “Events”

7. Click OK to close the Bookmark  dialog box.  A Bookmark  icon appears to the left of the
text that you entered indicating that the text is a bookmark.  This icon does not display
when viewed in a browser.

Creating a Link to a Bookmark

When you add a new page, you will also need to add a link to that page unless it is included in a
navigation bar.  Since the Home Page added in the previous step is not included in the naviga-
tion bar, you must add a link to it.  Any page in a Web site that has no link from another page is
an orphan page and is inaccessible to the viewer.  For this example, the new link will be to the
Bookmark in the Home Page.

1. If the Logical Layout window is not open, click the Site Manager–Logical Layout  tab to
open it.

2. Double-click the Other  page icon to open it in the Page Editor.

3. The Other page includes the Default Header and Default Footer that you previously
created.  Click below the Default Header and above the Default Footer (that is, in the space
between the two dotted-line boxes).

4. Select the Insert > Link menu option or click Link  on the Insert Objects toolbar to open the
Link  dialog box.

5. Click the Calendar Item  in the Page list box to select it.

6. In the Bookmark  list box, click to the arrow to the right of the <Begin> option to open the
drop-down list.
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7. Click the Events  item in the list box.

8. In the Link Text  box, type “List of Important Events”

9. Click Insert Link  to complete the link assignment.

The Other page now has a hypertext link to the Events bookmark in the Calendar page.

Creating Links to External Web Sites

You can insert links in Web pages to other Web sites regardless of the physical location of the
external “target” link.  External links can serve very useful purposes.

1. Click in the first cell of the table you just created.

2. Press the END key to move the cursor to the end of the cell (that is, to the right of the
image)

3. Press the SPACEBAR  to move the cursor one space to the right of the button image.

4. Type “Hotbot Search Engine”

5. Highlight “Hotbot Search Engine .”

6. Select the Insert > Link  menu option or click Link  on the Insert Objects toolbar.

7. Click the External  tab in the Link  dialog box.

8. The first item in the External  tab is the URL box.  Click the arrow to the right of the URL
box to open the drop-down list.  Click the URL type: “http://” .

9. Click in the blank box to the right of the URL selector box and type the text
“www.hotbot.com” This is the address for the Hotbot search engine Web site.

10. Click Assign URL  to complete the link assignment.  When you return to the Home Page,
the “Hotbot Search Engine” text is blue indicating that it is a hypertext link.  When it
displays in a browser, it appears in blue with an underline which is typical for a hypertext
link.

You have now created a link to an external Web site.



46 WebShop

Quick Start Guide

Using Artistic Text

WebShop features a wide variety of text manipulation effects that you can use to make your
Web pages more interesting to view.  To create artistic text, you must create an image box and
then enter the text.

1. Double-click the new Header  icon to open the header in the Page Editor  window.

2. Select the Insert > Image menu option or click the Image  button on the Insert Objects
toolbar to open the Image Attributes  dialog box.

3. Click Create  in the Image Attributes  dialog box.

4. Type the value “200” for Width  and “50” for Height .

5. Click OK to accept the values.

6. Click OK in the Image Attributes  dialog box to insert the blank image box.

7. A Blank Image  box appears at the top of the Page Editor  window.  Double-click inside the
Blank Image  box to open the Graphic Editor.

8. Select the Object > Add > Text Line menu option or click Text Line  on the Graphic Object
toolbar to open the Text Line  dialog box.

9. In the Text box, type “Welcome”

10. Click the Colors  tab to open the color selection features.

11. Click the Symbol  tab in the Colors  dialog box.

12. Click the Fill  tab in the Colors  dialog box.

13. Click the red color sample in the color sample box.

14. Click the Effect  tab.

15. Click the Shadow Right-Back  item in the Basic Effects  scroll box.  The sample box to the
right displays what the effect looks like.

16. Click OK to accept the changes.  When you return to the Header  window, the formatted
“Welcome” text appears at the top of the window.

17. Click outside the graphic box to place the image.

18. Click the graphic box to highlight it.

19. Select the Format > Center  menu option or click Center  on the Formatting toolbar to
center the image.

The text appears centered at the top of the header.  The “Welcome” text that you entered is now
a graphic image and may not be edited.
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Inserting Graphic Objects and Charts

Depending upon what version and options you have purchased with WebShop, the program
includes a Business Graphics Chart feature that allows you to create and insert a number of
different business graphics charts on your Web pages.

1. Place the cursor anywhere on the page you want to insert a business graphics chart.

2. Select the Insert > Image  menu option or click Image from the Insert Objects toolbar.  The
Image Attributes  dialog box appears.

3. Click Create  in the Image Attributes  dialog box.

4. Click the Size check box to place a check mark and click OK.  The Page Editor  window
now has an empty graphic box in it with the text, “Blank Image,” indicating that there is a
placeholder box for a graphic image.

5. Double-click inside the Blank Image  box.  The Graphic Editor  window appears.  Use this
window to import, create or edit graphics.  A blank graphic box appears.

Note: The New Object toolbar includes many type of graphic objects you can insert.  These
include patterns, frames, artistic and special effects text, drawing tools, calendars.  You can
even launch another application with the OLE button.

To insert business graphics, select the Object > Add > Chart  menu option or click Chart  on the
Graphic Objects toolbar.

6. The Chart feature allows you to create a number of different types of charts in different
styles and formats.  When you are finished editing the Chart attributes, click OK to insert
the chart into the Graphic Editor.

7. You can close the Graphic Editor or simply click on the Web page window.  The business
graphics chart is placed in the Web page.  You can resize it right in the Web page if you
want.  To do this, click on the graphic image once to select it, then drag the handles of the
bounding box to resize it.

Using Frames

You can divide a Web page into separate windows or frames.  Each frame is independent of the
other frames of the page.  A frame is the name given to the actual area on the screen defined
inside a bordered area.  The contents that the program displays inside a frame can be larger in
size than the frame itself.  In such a case, the program provides scroll bars to enable the viewer
to scroll vertically or horizontally to view the entire content of that frame.

The program treats all the frames placed on one page as part of one logical page.  However,
each frame (and its contents) is treated as a separate and distinct physical resource or page.
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Each frame has specific properties and can be re-sized and renamed.  Separate HTML files are
eventually created for each frame content as you generate the site.

It is recommended that you do not use too many frames in a single page due to the difficulty in
viewing such a page.

The Frame-Content Overlay (FCO) is the name given to the content of a particular frame.
Throughout this section on frames, the abbreviation FCO is used to denote “Frame-Contents
Overlay.” When a menu choice or dialog box by that title is being referenced, the full name for
FCO may be used to avoid confusion.

Important!  You can place more than one Frame-Content Overlay in any one frame.  This is
the reason why they are named “Overlays.”  Each different Content Overlay is another layer
in the same Frame.  The program enables you to create these FCOs, see them in a physical
layout list, and access them and edit any particular FCO that you want.  Without this frames
management capability you need to be an advanced Web designer with HTML programming
know-how, to be able to design a Web page which includes few frames, and where depend-
ing on what the viewer clicks in one of the frames, the content overlays in the other frame
change.  With WebShop this is easily done without any programming needed.

To create a Frame for a page

The program enables you to place vertical and horizontal frames on the page.  When you place
a vertical frame on the page, this means the screen or the page will be divided vertically and you
will have two frames, one on the left and another on the right.  In reality, it seems as though the
screen or page is being divided into two frames.  However, when you create a frame, the
program inserts a new frame on the page, and shows the borders of the frames with scroll bars.

1. To insert a horizontally divided frame on the page, select the Frames > Split
Horizontal  menu option or click on the Split Horizontal  button on the Page
Editor toolbar.  The screen will be horizontally split in the middle, and you will
see one frame at the top and another at the bottom, with the new frame you
inserted being placed above the current one you were in.

Note: The down arrow next to the Insert Split Horizontal frame button gives you two options.
You can either insert a new frame above the current one your cursor is in, or below it.  After
you insert a new frame on the page, you can simply click inside any of the frames visible
and create or edit that frame Content.

2. To split the page vertically and insert a frame either on the left or right side,
click on the down arrow of the Split Vertical  button.  Choose which side (left or
right) you want to insert the new frame.
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Renaming a Frame

Each frame should have a unique name.  Since a frame also contains at least one FCO, then that
FCO should also be named.  Furthermore, if frames have more than one FCOs, then each FCO
should also be uniquely named.  This is important such that when you want to access a specific

frame and a specific FCO, you can do so easily from the list of available frames and FCOs.  The
program by default gives unique names to all of the frames and FCOs as soon as you create
them.  It keeps them in its internal database, and manages them properly so that you can access
them or link to them from any part of your Web site.

You can rename the Frame and FCO names that the program automatically assigns.  You may
want to do this to provide a more descriptive name for your development.

To rename a frame

1. Click on the Frame Manager  button from the toolbar.  

The physical layout of the frames and the FCOs is displayed on the left.  In this example the
frame manager displays the following:

FrameSet1 –is the name of the entire Web page.  It
contains two frames.
Frame–is the name of the first frame.
Index –is the name of the Frame-Content Overlay (FCO)
in the frame called “Frame.”
Frame1–is then name of the second frame.
Page1–is the name of the Frame-Content Overlay (FCO)
in the frame called “Frame1.”
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2. Click on Frame1 , then click on it once more.  A box
around the frame name appears.

3. Edit the name and press the RETURN key.

Note: You can achieve the same result by right-clicking on
any frame named in the list, and selecting the option
Rename.

You can also rename any of the items listed in the Frame
Manager window including Frame Content Overlays (FCOs).  For example, to rename the FCO,
called Frame1, right-click on it and enter the new name you want.

Adding Frame Content Overlays (FCO)

You can add as many FCOs to a frame as you like.  Each one will be another layer displayed
inside that frame.  The different FCOs are displayed to the viewer when the viewer clicks on the
corresponding links inside another frame.

To add a new FCO inside a frame

1. Click on the Frame Manager button.

2. The Frame Manager window appears.  This window displays a list of frames and FCOs.
Right-click on one of the frames you want to add a new
FCO.  From the pop-up menu select New Frame-
Content Overlay .

From the Add Frame-Content Overlay  dialog box, choose
one of the types of frame (FCO) pages you want to add and
click OK.  The Add Frame-Content Overlay  dialog box
provides you with the choice of adding new resource frames,
or even using one of your existing frame resources.

To add a new frame resource, select the Use New Resource
Frame  tab.  The different types of page styles you can create
or add are:

••••• Plain Page .  Use this when you want a plain simple Web page with a line by line structure.

••••• Frame Set .  Use this when you want nested frame sets (that is, when you want to insert a
set of frames inside another frame).

••••• Free Page .  Use this when you want to place graphic or text objects anywhere on the page.
This is the more versatile page style where you are not limited by the text line limitations of
Plain pages.  If you want to be artistic, place objects on the page, and drag them, even use
snap to grid options and transparent overlaps, then use this type of a page.
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••••• Image .  Use this when you want to create graphic image file for your page.  This is a page,
which can be one or more images.  You can insert an image inside a Web page or FCO, but
that is not the same as using an “Image” page.  An Image page is converted to one graphic
image file in your site.  Browsers support this special feature whereby when the viewer
clicks on the appropriate link the browser displays the complete image in that frame.  This
page will not generate into an HTML page in your site.  It will exist as an image file.  One
common use of this feature is to place many image pages inside a frame, and their corre-
sponding links in another frame.  As the viewer clicks on the links one after the other, the
images are successively displayed in the other frame like
a slide show.

••••• Dynamic Page .  Use this when you want to create a page
that displays text or form elements that contain instruc-
tions executed by your ISP server.  This is not a tradi-
tional page with text or graphics objects, instead this page
contains instructions that are executed by your ISP server
and which display data, interactively.  These pages
perform dynamic actions based on different parameters.
Active Server Pages (ASP) is the technology used to
perform Dynamic Page instructions.

This example displays a frame with many different types of
Frame-Content Overlays added.   Frame1  has eight Frame-
Content Overlays.

If you created frame resources in your Web design project
before, and instead of adding a new frame resource you
wanted to use one of them, click on the Use Existing Resource  tab in the Add Frame-Content
Overlay  dialog box.  The window will display the list of page and image resources you cur-
rently have in your project.  Simply select the one you want and click OK.

Adding Content to a Frame-Content Overlay

Adding content to a Frame-Content Overlay requires that you display a specific Frame-Content
Overlay and add (or edit) the information as you would with a Plain Page.

To access (or display a specific FCO)

1. From the Frame Manager  window, click on the Frame-
Content Overlay you want to access.

2. Move your cursor into the frame and click on the open
area to activate the frame.  Now you can start composing
or editing information.

You can also access a Frame-Content Overlay from the
Frames and Page Editor toolbar.  Click on the current frame
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listed in the FCO drop down box.  Click on the down arrow and from the list of available FCOs
select the one you want.

Linking to Frame-Content Overlays
To use FCOs for the right purpose, you must provide links in one frame of your page, which
correspond to the FCOs that you want displayed in another frame of the page.

To link a text line or object in one frame to a specific FCO in the other frame

1. Select the text line or object you want to link, then select Insert > Link  menu option.  The
Link  dialog box appears.

2. Click To Resource  tab.

3. From the Frameset  drop-down box, select “index .htm .” In the event that you have more
than one frame set, you can choose the frame set you want.

4. From the Frame  drop-down box, select the frame (which contains the specific FCO) you
want.

5. From the Frame-Content Overlays  drop-down box, select the name of the Frame-Content
Overlay to which you want to link.

6. Click Assign URL .

7. Press F7 to test your links.  The browser is launched and you can test your links by clicking
on them.

Navigation Bars and Linking to FCOs

The Navigation Bar feature is a powerful method to create links between frames.  You can do
this manually with your own links.  This was described in the previous section.  However, the
Navigation bar feature—also known as NavBar —provides a more automated method for
creating and placing your links.  When you use the NavBar method, the program keeps track of
the links.  When you delete a page, its respective links (or buttons) are removed.  When you add
a page or FCO, the program automatically adds a corresponding link or button to all the
appropriate pages or FCOs.

To add a NavBar in one frame, which will create buttons that link to the Frame-
Content Overlays of another frame

1. Follow previous instructions to place two vertical frames on your page.  You should have a
left frame and a right frame.  See the procedure “Adding a Frame Content Overlay.”

Note: This example will describe how you can place a NavBar in the left frame, which will
link to different FCOs in the right frame.

2. Add three FCOs in the right frame.  To do this:

A. Click on the Frame Manager  button and select Frame , the name of the right frame.

B. Right-click on Frame , and from the pop-up menu, select New Frame Content
Overlay .  Select Plain Page  and click OK.  This will add Page2 to the list of FCOs.
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C. Right-click on Frame  and repeat this step two
more times to add two more FCOs.

D. Click once on the Index FCO of Frame FCO.
The corresponding FCO will be displayed in the
right frame window (which is not displayed in
the graphic).

E. Place the cursor in that frame and type “This is
the first FCO.”

F. Click on the other FCO names in the Frame
Manager  window and type different text in the
other FCOs, which are displayed in the right frame.  Now all three FCOs of the right
frame have different contents.

3. In Page Editor, place the cursor in the left frame and select Insert > Navigation Bar .  The
Insert Navigation Bar  dialog box displays.  The default style NavBar is previewed.

Note: Since we want to link these NavBar buttons to Frame-Content Overlays and not to the
other pages, select To Frame Content-Overlays in same page from the Navigation section.

4. Customize your NavBar.  To do this:

A. Select the Custom  option.

B. From the Target Frame  drop-down box, select the frame that has your three FCOs.

C. In the Style  section, select the Siblings of the same parent  option.

D. Either double-click on the sample NavBar or click on Edit  button.

E. In the Type of NavBar , select Image with label .

F. In NavBar Orientation , select Vertical .

G. In the NavBars Button Groups , select Siblings buttons .

H. Click on Font and Choose Image buttons to make your choices for the style of
button labels and the button graphics.

I. Click OK  twice.  The vertical NavBar you designed is placed in the left frame.
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Note: As you can see, it has three buttons.  Each button is a link to its corresponding FCO in
the right frame.

5. To test the links, click on F7, or select File > Preview in Browser .  After the browser
displays the page with the two frames, click on the buttons in the left frame.  The FCOs in
the right frame will change.

Note: If you change the names of the Frame-Content Overlays or add new ones, the buttons
on the NavBar in Frame1 are automatically updated.

Inserting HTML Code

WebShop features a What You See is What You Get (WYSIWYG) environment where you
design the Web pages and it generates the necessary HTML.  There are a number of advantages
to this system:

• The HTML code is error-free since it is generated by the program and not by hand.

• You do not have to learn HTML coding language or keep up with the ever-changing
HTML variations.

• WebShop converts graphic formats and designs into optimized HTML objects.  For
example, most HTML editors cannot import vector images or Windows bitmapped images.
Internet browsers cannot view them.  WebShop enables you to import a number of different
graphic formats, including Windows Bitmapped images, and then automatically converts
them to the best format for use with Web browsers.  This saves you the time and effort of
having to manually convert text and images to proper HTML compatible formats.

However, if you are an advanced user and would like to insert your own HTML code, you can
use the HTML Insert feature.  With this feature, you can also insert comments into a Web page.
These comments are not visible when a user views a page in a browser unless they select the
View Source option to see the HTML source code for the page.



WebShop 55

Quick Start Guide

To insert HTML code

1. If the Site Manager-Logical Layout  window is not open, click on the Logical Layout  tab
to open it.

2. Double-click on one of the pages and place the cursor where you want to insert your
HTML code.

3. Select the Insert > HTML Code menu option or click HTML Code  from the Insert Objects
toolbar.

4. Type “<!— This is comment text.  It is not visible in the browser page.  —>” in the
HTML Code Editor  dialog box.

5. Click OK to insert the HTML code into the Web page.

Using Multimedia Objects

If you wish to add new types of objects to your Web site, such as music or video files, it is
helpful to place them in a dedicated new folder in the physical layout of your project.  This
helps you keep the Web site files organized more efficiently.

To create folders for individual types of multimedia files

 1. Click the Physical Layout  tab from the Site Manager  window.

 2. Click the first entry in the tree listing, once, to select it.  This is the root folder.

 3. Right-click on this folder to open the drop-down menu.

 4. Select Create > Folder .  The new folder appears.

 5. Type the new folder name “Music”

 6. Click the Music  folder that you just created to select it.

 7. Right-click the Music  folder to open the drop-down menu.

 8. Select the Import > Multimedia menu option.  The Open  dialog box appears.

 9. Open the Windows  folder on the C drive.

10. Click on the arrow to the right of the Files of Type  selector to open the list box.

11. Click the Audio Files  item from the drop-down list.

12. Scroll down through the Windows  folder or search in the Media folder until you locate an
audio file (either a MIDI or a WAV file).

Note: For an NT system, these files could be in another system folder area.

13. Click the Audio  file in the Open  dialog box to select it.

14. Click OK to insert the file into the resource list in the “Music”  folder.

This inserts the sound file as a resource, but this resource, at this point, has not been placed on
any page in the Web site.
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Inserting Multimedia in the Web Page

You can insert a multimedia file anywhere on a page.  In the case of sound files, you may want
a multimedia file to begin playing as soon as the browser opens the Web page.  The Autostart
feature controls this feature and can be turned on or off when you embed the multimedia object.
To continue the example we started before, we will place on the Web page the multimedia file
we imported.

To insert a multimedia file on the page

1. In Page Editor, place the cursor anywhere on the Home Page  window where you want to
insert the multimedia object.

2. Select the Insert > Embedded Object  menu option or click the Embedded Object  button
on the Insert Objects toolbar.  The Embedded Object Properties dialog box appears.

3. The Select Embedded Object  window lists the “Music”  folder where you placed the
multimedia object in the previous section.  Click + (plus sign)  to the left of the “Music”
folder to open the folder tree beneath it.

4. Click the audio file that you imported in the “Inserting Multimedia Objects” procedure
earlier.

5. In the Type  section, click the Sound  radio button to designate the file as a sound file.

6. Click the Autostart  check box to turn the feature on.  This will make the sound file start
playing as soon as the browser displays the page.

7. Click the Hidden  check box to hide the audio file when it opens in the browser.  Click OK.

Note: The sound file appears as a gray button with a speaker on the Web page.  This will not
display like this when you generate this page as an HTML file.  At that point, it will disappear
because it is defined as a Hidden object.

8. To test this page with the multimedia object, click on the Preview  button or select File >
Preview in Browser .

Navigate Layout

The Navigate Layout  window graphically displays the Web site with all of the resources and
links in the site.  These include links and resources that are outside the Web site.  This window
is most valuable in checking your Web site for missing links, orphan pages (that is, pages that
have no links to them), and the site structure.  While the Logical Layout window shows the Web
site structure of the physical pages, the Navigate Layout window displays all of the resources,
such as HTML pages, Frame-Content Overlays, images, multimedia files, and special features.
Arrows are used to display the current links between resources.

It is a good idea to examine the Web site in the Navigate Layout window periodically as you
assemble the various elements to insure that the navigation organization is correct.  You should
also check the layout before you generate the Web site to ensure that all of the elements and
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links are in place.  In the Site Manager, click the Navigate Layout  tab to graphically view your
entire Web site.

Previewing the Web Site

WebShop features a Preview option that allows you to view any page in the current Web site
quickly and easily.  This feature saves you the trouble of having to generate the Web site and
then open your browser just to see what a page looks like.

1. If the Home Page is not open in the Page Editor  window, double-click the Home Page
icon to open it.

2. Select the File > Preview in Browser menu option or click the Preview  button on the Main
toolbar.

WebShop opens the current page in a new browser window that enables you to see how the
page will appear when viewed in a standard browser.

Generating the Web Site

WebShop stores all Web site information, including all graphics, in a single, proprietary file.
This keeps all of the design elements together so that they will not be misplaced or lost.  It also
facilitates moving the Web site from one computer to another since you only have to move one
file.  The process of generating a Web site causes WebShop to create all of the HTML pages
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and accompanying graphics that are necessary for the Web site.

1. Before you generate the Web site, it is a good idea to save the project.  Select the File >
Save menu option or click Save on the Main toolbar to save the project.

2. Select the File > Generate Site menu option or click the Generate Site button on the Main
toolbar.  The Browse For Folder dialog box appears.

3. Select the folder where you want WebShop to place your files.

Note: The Generate Site feature will create a new folder named “WebSite”.  All of the sub
folders and files necessary for the site will be created and placed in the “WebSite” folder.

4. Click OK.  The program begins processing.  When finished the message Site successfully
generated  appears.

This completes the process of designing and generating a Web site.

Viewing the Web Site

When you finish generating the Web site, you can view it in an Internet browser, such as
Netscape Communicator or Internet Explorer—provided you are not using Active Server Pages
(ASP) or a predesigned E-commerce template.

Unlike standard Web pages, you must generate and upload your site to an NT-server that is
100% compatible with Active Server Page (ASP) technology before  you can view and test your
E-commerce Web pages with a browser.  Because your E-commerce Web pages make use of
ASP technology, to function properly, they must access and update the database that stores your
products and customer orders.

To view your non-ASP pages

1. Open your Internet browser.

2. Select the File > Open File menu option (or whatever menu option you use in the browser
to open a file on your hard drive).

3. Select the Index .htm  file from the WebSite folder that you created in the Generate Site
operation.  You should now be able to view your Web pages in the browser.  Test all of the
hypertext links to make sure that you can access each page properly.

4. When you are satisfied that the Web site appears as you wish, you are ready to upload it to
a Web-server.

Changing Visual Settings

WebShop provides extensive support for changing the visual settings of your Web pages.
WebShop does this through Styles.  Styles enable you to set the different objects of your Web
page to conform to a general set of attributes.  For example, you can set the color, size and
format of bullets, horizontal rules, headings, body text, banners NavBars, backgrounds and
other objects.  Once you set them as you like, when you insert an object it will have the color or
settings that you had set in the styles.
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The program comes with a set of predefined styles.  You can create your own styles and use
them in your current project or add them to the library of styles.  You can even modify the
styles that are in the Styles library to fit your need.

When you first start the program, a very plain style is applied to the pages.  You can choose
another style to apply or you can change the visual settings of one page.  These different style
options are created by the three categories of style options: Default, Specific, and Custom styles.
A default style is the style currently applied to the Home Page.  It defaults (or is inherited) by
every page below it.  A specific style is currently available site style.  Specific styles must be set
up in Site Manager before they become available.  Custom style is a single page application of a
specific style.  You create a custom style by selecting a specific style then change its visual
settings.

To use the default style

1. Place the cursor in the page you want to apply the default style.

2. Right-click in the open area.  A pop-up menu appears.  Select Style .  The Page Style
dialog box appears.

3. Click on the Default Style  radio button to inherit the style from the next highest level.

4. Click OK.

The Default Style (Inherit from higher level)  radio button, enables you to set the visual settings
of this page to the style of its parent page (that is, the next highest level page).  If the page is a
Home Page and has no parent page, the Default style is applied to the Home Page.
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To use a specific style

1. Place the cursor in the page you want to apply a Specific Style.

2. Right-click in the open area.  A pop-up menu appears.  Select Style .  The Page Style
dialog box appears.

3. Click on the Specific Style  radio button to make available the specific style drop-down list.
Select the specific style that you want.

Note: When you first start a project there is only one style, it is the default style.

4. Click OK.

To design or add more styles to the Specific Style drop-down list

Your current project may have a number of predesigned styles that came with the program and
others you may have designed.  You must specify the styles you want in the Site Manager
before they become available for use on individual pages.

1. In the Site Manager  window, click the Styles tab.  The Site Manager–Styles  window
appears.

Note: The Site Styles column lists all the styles that are available and usable in your current
project.  The Styles Library column lists all the pre-made styles available for you.  To use
some of these styles for your pages, you must select them in the library column and add or
insert them in the Site Styles column.

2. Right-click on any style in the Styles Library  column.  A pop-up menu appears.

3. Select Insert Style .  The selected style is inserted in the Site Style  column.  You can add as
many styles as you want.

4. Once you have inserted all the styles you want, go to the Web page to which you want to
assign a specific style.  Right-click in the open area and select the Style  option from the
pop-up menu.  The Page Style  dialog box appears.

5. Select the Specific Style  radio button and from the pop-up menu select the style you want
to apply or use in this Web page.

6. Click OK.

Note: Now when you insert an object in this page, it will follow the attributes and format of
the Style you have chosen.  For example, if you select a text line and from the text format-
ting buttons you select it to be Heading1, it will be converted to the style and colors of the
Style currently in use.  The same applies for bullets, horizontal rules and other objects on
the page.
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To use custom styles and change a style for the current page

1. Right-click on the page and from the pop-up menu select Style .  The Page Style  dialog
box appears.

2. Click the Custom  radio button with the default selected in the Specific Style  drop-down
list.

Note: The changes you will make will apply to the
Default Style.  To change to another style, before you
set the Custom radio button, click on Specific Style
radio button, and from the pull down menu select any
style you want to customize.

3. Double-click on any part of the sample style to
change it.  In this case, double-click on the Banner
object.  The Banner Style  dialog box appears.

4. Make your changes and click OK.

5. Double-click on any other object controlled by the
style.  You can customize the entire style if you
want.

6. To change the colors of the background, double-
click on an area of the Style away from the text or
labels.  The Page Background  dialog box appears.
Once you have done all your changes, click OK.
The Page Style  dialog box appears
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7. Click OK to save your changes.

Note: The Style is applied to your current page.  It is also applied to all the children pages of
this page, provided those pages are set to inherit styles from higher level or parent page.

Uploading Your Web Site to a Web Server

Before you begin you will need to have your hosting service’s Internet domain name, your ISP-
assigned user name (or user login) and password.  In general, it is not necessary to know your
exact directory address (or upload path).  All NT-servers with Microsoft Internet Information
Server (IIS) installed identify folder address locations by user name.  However, if you currently
are hosting more than one site with the same provider, you will need to specify your exact
account location.

If you want to use the Boomerang Software Web-hosting service, contact webhosting
@boomerangsoftware.com to obtain the proper information.  Then follow these steps.

To upload your Web site to a Web Server

1. Select the File > Upload Site .  The Upload Web Site  dialog box appears.

2. Type your FTP server name or address in the FTP Server Name or Address  text box.

Note: The FTP Server Name or Address text box defaults to the Boomerang Software Web-
server.  If you wish to upload to a different Web-server, simply press the SPACEBAR and
enter the FTP server address of your target Web-server.

3. Type your user login name in the User Login  text box.

4. Type your password in the Password  text box.

5. Type your Upload Path .

Note: The Upload Path text box allows you to specify the Web-server directory or folder in
which to load your Web site files.  For example, if your Web site URL is www.uswebx.com/
richard, you would type “/richard” in the Upload Path text box.  Many Web servers are case
sensitive, so be sure to enter the folder name exactly as it appears on the Web-server.  If
you are not sure about the proper Upload Path, contact your Web-server administrator.

6. Click Upload .

When the process of transferring your Web site files is complete, you may establish an Internet
connection, log onto the World Wide Web, and go visit your new Web site!

Note: One of WebShop’s important features is its ability to manage databases.  If you have
opened an E-commerce Web site, your Web site will have one *.MDB file with several
database tables.  These could be products that you are selling on the Web from your
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WebShop, or customer names that have bought products.  When you upload a new revised
Web site, you may not want to overwrite the existing database on the server.  For this
reason, the Upload Web Site dialog box includes the Upload Database check box.  If you do
not want to upload the database along with the rest of the site, then click on the Upload
Database check box to uncheck it.  Refer to the E-Commerce User Guide for more details.

Changing the ECStyle for an E-Commerce Template
Every E-Commerce Template comes with two predefined Site Styles: Default Style and
ECStyle.  The Default Style is a very basic style. Use it to practice making style modifications.
It is not the default style for your template.  It has been inserted in case you want to create a
Style Sheet of your own.  When opened, each page in your template uses ECStyle.  ECStyle is
the default style for your E-Commerce Template.

To change ECStyle, you must decide if you want to replace ECStyle with an entirely different
style sheet or if you want to modify one or more of the existing style sheet elements.  Both of
these are important options.  One gives you an entirely different look by using an entirely new
Style Sheet and the other enables you to customize one or more of the existing style sheet
elements.

Assigning a New Style Sheet to ECStyle
To assign a new style sheet to ECStyle you must either

• Insert a library style into the Site Style listing or

• Create a custom style based on Default Style–Base

Once you have defined the new style that you want to use in place of ECStyle, then you must
delete the existing ECStyle, rename the new style “ECStyle,” and set the new ECStyle to be the
default style

Customizing the Existing ECStyle
To modify (or customize) the existing ECStyle you must

• Determine what style sheet elements you want to change

• Change the current settings for those elements that you want to change

You do not need modify the ECStyle name as it appears in the Site Style listing.

To begin working on styles

• From Site Manager, click the Styles tab.  The Site Manager—Style window appears.

This dialog box is used to define styles for use with your Web site.  It has three parts:  Styles
Library  list box and listing area, a Site Styles  display area and a Preview  area.   By default, the
Styles_A  Style Library is selected.  Click Styles_A01 to see a preview.  By previewing styles
from the Style Library, you can decide which of the predefined style sheets you want to use.
Once you select a style you want, insert it into the Site Styles list.  To insert a Library Style into
the Site Style list
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1. Highlight on the style you want and right-click.  A pop-up menu appears.
2. Select Insert Style .

The style you selected has now been inserted into the Site Styles  display area.  It is now
available for use.  You can insert as many Library Styles as you want.  If you do not like any of
the Library styles, you may also create a Custom Style.

To create a custom style

1. Right-click in the Site Styles  box (in the white space).  A pop-up menu appears.

2. Select New Style .

Making a new style creates a copy of the Default Style.  By default, any custom style based on
Default Style is named Style , Style1 , Style2 , successively.  You should rename your custom
styles so they have a distinctive name, one that tells you how that style will be used.

To rename a style

1. Highlight the style you want to rename and right-click.  A pop-up menu appears.

2. Select Rename .  A box appears around the style name.

3. Type the new name.

Once you have renamed the style, you are ready to customize the style.

To modify (or customize) a style

1. Highlight the style in the Site Styles list.

2. In the preview area, select and double-click on the style element that you want to modify.

Note: Style previews are divided into different areas.  You may want to experiment with
several just to learn how style elements are grouped.  For example, highlight the word
“Banner” (dotted lines appear) and double-click the box.  The Banner Style  dialog box
appears.

3. From the dialog box that appears, choose the options you wish to change.

Note: There are five dialog boxes that might open depending upon what style elements you
select.  These include NavBars, Headings, Font Styles, Bullets and Numbering.  To change
a style, you may need to play with the various options used with each of these dialog boxes
to see just how they work.

4. When you are done, click OK.  Your change is now reflected in the preview area.

Note: If you want to use a custom image for a banner, bullet, or other graphic object, you
can insert new images into the one of the several image libraries.  You can do this by
selecting on Library > Edit  Image Library .  The Edit Library  dialog box appears.  Use the
drop down menu in the Library Type  box to select the library.  Then locate the image that
you want to add in the top most Look In  box.  Highlight the image file that you want and
click Add .  When done, click OK.  When you go back to insert the graphic image, the image
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will be there.

You can customize all of the different sections of the Style sheet using the above procedure.
The parts of the Style Sheet that can be changed include NavBars, Headings, Font Styles,
Bullets and Numbering.  When done, you might want to set one of your customized Site Styles
as the Default Style.

To set one of the site styles as the default style

1. Highlight the style that you want to be the default and right-click.  A pop-up menu appears.

2. Select Set as Site Default Style .  A red check mark appears next to the icon for that style
sheet.  This indicates that it is the default style.

Note: When changing the default style for an E-Commerce Template, you must use the
name “ECStyle.”  Your E-commerce dynamic pages use this style as a specifically assigned
style.  There must always be one style in the Site Styles listing called “ECStyle.”   You may
assign other pages different styles with different names, but to function properly, your
WebStore’s dynamic pages must be set to ECStyle.
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License Agreement and Warranty

IMPORTANT

Opening the software package and using WebShop Designer indicates acceptance of the terms of this License Agreement.

NOTICE OF COPYRIGHT

This software program package (“SOFTWARE”) is a proprietary product incorporating elements developed by Boomerang
Software, Inc.  (“BOOMERANG”).  This software is protected by copyright laws and international treaty.  You must treat the
SOFTWARE like any other copyrighted material, except that you may either make one copy of the SOFTWARE for backup or
archival purposes, or you may place the SOFTWARE on a single mass storage device (media), such as a hard disk, provided
that you keep the original software for archival or backup purposes.  Copyright laws prohibit making additional copies of the
SOFTWARE for any other reason.  You may not copy written materials accompanying the SOFTWARE without the express
permission of BOOMERANG.

The WebShop Designer program, its screens, icons, sequence, and organization are copyrighted materials of BOOMERANG.
They may not be copied or duplicated in any medium without the written authorization of BOOMERANG.

SOFTWARE LICENSE AGREEMENT

The software on the WebShop Designer media is licensed to the user.  Before using WebShop Designer, you should carefully
read the terms and conditions of this Agreement.  This Agreement is a legal contract between you (the end user) and
BOOMERANG governing your use of the software.  If you do not agree with these terms and conditions, please return the
software with all accompanying packaging materials to the vendor from who you purchased it for refund or credit.  Return
policies of vendors may vary; you should check with your vendor as to their return policy on returning unused, unregistered
software.  Return of software is subject to restocking charges and terms which will be applied and deducted from the initial
cost paid by the customer returning the software.  This agreement shall also be binding on any subsequent authorized licensee.
If you have questions regarding this Agreement, contact BOOMERANG at 617-489-3000.

A. BOOMERANG grants you the right to use one copy of the software on a single-user computer only.  Installing the
SOFTWARE on a multi-user computer or network server is a violation of this Agreement.

B. BOOMERANG further grants you the right to make a backup/archival copy of the SOFTWARE as set forth in the
Notification of Copyright.

C. You may not sublicense, rent, or lease the SOFTWARE, but you may permanently transfer your license to use the
SOFTWARE and accompanying materials by delivering to another party the original media (that is, the CD-ROM), and
original user documentation materials comprising the SOFTWARE package.  The new recipient of the SOFTWARE and
accompanying materials accepts this Agreement and is licensed under the terms of this Agreement upon initially using the
SOFTWARE.

LIMITED WARRANTY / LIMITATION OF REMEDIES

BOOMERANG warrants the original media (that is, the CD-ROM) on which the SOFTWARE is recorded to be free from
defects in workmanship under normal use for a period of thirty (30) days from the date of your purchase as evidenced by a
copy of the original receipt of payment.  BOOMERANG’S entire liability and your exclusive remedy will be replacement of
the media that does not meet BOOMERANG’S limited warranty and is returned to BOOMERANG with a copy of the original
receipt of payment.  BOOMERANG will have no responsibility to replace media that has been damaged by accident, abuse, or
misapplication.



WebShop 67

Quick Start Guide

Under no circumstances including negligence, shall BOOMERANG be liable for any incidental, special, or consequential
damages that result from use or inability to use the SOFTWARE or related user documentation, including all user documenta-
tion delivered in digital format, even if BOOMERANG or any BOOMERANG authorized representatives have been advised
of the possibility of such damages, or that result from mistakes, omissions, interruptions, deletion of files, errors, defects, or
delays in operation or any failure of performance whether or not caused by events beyond BOOMERANG’S reasonable
control, including, but not limited to, acts of God, computer failure, theft, destruction, or unauthorized use of BOOMERANG
program or services provided by BOOMERANG in connection with the publication of the software covered by the License
Agreement.

Because any individual software title which (1) creates files combining multimedia functionality with hypertext markup
language (HTML) functionality and (2) is designed to create a commercial Web site (“WEB STORE”) to facilitate electronic
commerce over the public Internet is subject to many factors beyond the reasonable control of BOOMERANG, including but
limited to the known incompatibilities among widely-distributed programs for viewing HTML files over the public Internet
and private Internet Protocol (IP) networks, improper, insufficient, obsolete, or inoperable hardware or software configurations
on remote PCs accessing the public Internet or private IP networks, unforeseen congestion on the public Internet or private IP
networks, failure of public telecommunication transmission providers, failure of unknown third parties to deliver access to the
public Internet or the legal or illegal use of public and private communication systems by unknown third parties, you are
advised to verify all work created with this SOFTWARE.

You are further advised to verify all confirmed or unconfirmed attempted transactions from any fully identified or partially
identified end user (“CUSTOMER”) accessing the WEB STORE and strongly encouraged to make backup copies of all files,
reports, email or any other administrative information generated as a result of work created with this program or attempts to
access Web sites generated through the use of this program.

BOOMERANG is in no way liable for the failure of any single electronic commerce transaction or any series of transaction
authorization failures experienced by one or more end-user merchants using this SOFTWARE program to sell any product or
service over any public or private communication system or by an end-user attempting to access any file or Web site through
any public or private communication system to purchase any product or service created by any licensed or unlicensed user of
this program.

Boomerang Software, Inc.  cannot assume any responsibility or liability for any indirect, special, incidental, economic, cover
or consequential damages arising out of the use of or inability to use WebShop Designer or any component of the documenta-
tion included with the program, including any and all documentation delivered in digital format.  In no case shall Boomerang
Software be liable for any amount exceeding the purchase amount paid by a licensed user for the software.

The information contained in the WebShop Designer documentation is subject to change.  Except as specifically provided,
Boomerang Software makes no warranty or representation, promise or guarantee, either express or implied, statutory or
otherwise, with respect to this software or user documentation, including their quality, performance, merchantability, or fitness
for a particular purpose.  No Boomerang Software dealer, agent distributor, or reseller is authorized to make revisions to this
warranty.

Revisions to any component of the program or user documentation included with WebShop Designer may occur as deemed
necessary by Boomerang Software, Inc.  The information herein is believed to be, and is presented to be, accurate in all
respects.  However, Some states do not allow the exclusion or limitation of implied warranties or limitation of liability for
incidental or consequential damages, so the above limitation or exclusion may not apply to you.

MS DOS, Windows, NT, Internet Explorer, Active Server Pages and True Type are trademarks of Microsoft Corporation, IBM
is a trademark of International Business Machines Corporation, Navigator is a trademark of Netscape Communications, and

PhotoSuite is a trademark of MGI Software.

All other product names or trademarks identified in the user documentation accompanying this SOFTWARE are trademarks or
registered trademarks of their respective companies.  They are used in this book in an editorial fashion only.  No such use, or
the use of any trade name, is intended to convey endorsement or other affiliation with Boomerang Software products.
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